summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-03 22:20:46 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 19:22:25 +0200
commit09ac892a951aeded1bc6d0487980041fb55a71b7 (patch)
tree99b4418d75737c8bd3123675415553a741466970 /gnu/packages/hurd.scm
parent7aad4609ae38790b7cc4e6a88b3e48ab43bc1f09 (diff)
downloadguix-patches-09ac892a951aeded1bc6d0487980041fb55a71b7.tar
guix-patches-09ac892a951aeded1bc6d0487980041fb55a71b7.tar.gz
gnu: hurd: Use a 32-bit MiG when cross-compiling.
* gnu/packages/hurd.scm (hurd)[native-inputs]: When '%current-target-system' is true, pass #:system "i686-linux" to 'mig'.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index ca7d7e97a3..6478eb4434 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -370,7 +370,13 @@ boot, since this cannot be done from GNU/Linux."
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)
- ("mig" ,mig)
+ ("mig" ,(if (%current-target-system)
+ ;; XXX: When targeting i586-pc-gnu, we need a 32-bit MiG,
+ ;; hence this hack.
+ (package
+ (inherit mig)
+ (arguments `(#:system "i686-linux")))
+ mig))
("perl" ,perl)
("texinfo" ,texinfo-4)))
(supported-systems %hurd-systems)