summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-06-02 23:28:07 +0200
committerLudovic Courtès <ludo@gnu.org>2014-06-02 23:28:07 +0200
commit0497ba3b260527d4184a0fcb22d6ab30e5e11a63 (patch)
tree69bae9b9ec9b3e4930938607a98e639e4ef1bc61 /gnu/packages/hurd.scm
parentbc046a94dec2afadbc1ee3957f13098a8d8b393c (diff)
downloadguix-patches-0497ba3b260527d4184a0fcb22d6ab30e5e11a63.tar
guix-patches-0497ba3b260527d4184a0fcb22d6ab30e5e11a63.tar.gz
Revert "gnu: hurd: Add Hurd Minimal."
This reverts commit bc046a94dec2afadbc1ee3957f13098a8d8b393c, which referred to uncommitted things ('glibc/hurd-headers'.)
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm67
1 files changed, 1 insertions, 66 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 346a37bf3e..f1e7dbc9dc 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -20,14 +20,11 @@
#:use-module (guix licenses)
#:use-module (guix download)
#:use-module (guix packages)
- #:use-module (gnu packages)
#:use-module (guix build-system gnu)
#:use-module (gnu packages flex)
#:use-module (gnu packages bison)
#:use-module (gnu packages perl)
- #:use-module (gnu packages autotools)
- #:use-module (gnu packages base)
- #:use-module (guix git-download))
+ #:use-module (gnu packages autotools))
(define-public gnumach-headers
(package
@@ -131,65 +128,3 @@ communication.")
"This package provides C headers of the GNU Hurd, used to build the GNU C
Library and other user programs.")
(license gpl2+)))
-
-(define-public hurd-minimal
- (package
- (name "hurd-minimal")
- (version "0.5")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "git://git.savannah.gnu.org/hurd/hurd")
- (commit "a5ca1de1eb575294dbc865a2c4ff643efc117ef4")))
- (sha256
- (base32
- "17vqdlpy1ifw4ijhc3ydkp8p5d406c7aq4ghpmg4a1h1wlwy32kr"))
- (file-name (string-append name "-" version))
- (patches (list (search-patch "hurd-minimal.patch")))))
- (build-system gnu-build-system)
- (inputs `(("glibc-hurd-headers" ,glibc/hurd-headers)))
- (native-inputs
- `(("autoconf" ,autoconf-wrapper)
- ("mig" ,mig)))
-
- (arguments
- `(#:phases (alist-replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let ((out (assoc-ref outputs "out")))
- ;; We need to copy libihash.a to the output directory manually,
- ;; since there is no target for that in the makefile.
- (mkdir-p (string-append out "/include"))
- (copy-file "libihash/ihash.h"
- (string-append out "/include/ihash.h"))
- (mkdir-p (string-append out "/lib"))
- (copy-file "libihash/libihash.a"
- (string-append out "/lib/libihash.a"))
- #t))
- (alist-replace
- 'build
- (lambda _
- (zero? (system* "make" "-Clibihash" "libihash.a")))
- (alist-cons-before
- 'configure 'bootstrap
- (lambda _
- (zero? (system* "autoreconf" "-vfi")))
- %standard-phases)))
- #:configure-flags '(;; Pretend we're on GNU/Hurd; 'configure' wants
- ;; that.
- "--host=i686-pc-gnu"
-
- ;; Reduce set of dependencies.
- "--disable-ncursesw"
- "--disable-test"
- "--without-libbz2"
- "--without-libz"
- "--without-parted")
- #:tests? #f))
- (home-page "http://www.gnu.org/software/hurd/hurd.html")
- (synopsis "GNU Hurd libraries")
- (description
- "This package provides libihash, needed to build the GNU C
-Library for GNU/Hurd")
- (license gpl2+)))