summaryrefslogtreecommitdiff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorManolis Ragkousis <manolis837@gmail.com>2014-02-16 10:17:52 +0000
committerLudovic Courtès <ludo@gnu.org>2014-02-16 19:52:59 +0100
commit0193c004322821409e7130f601c0ece676b32665 (patch)
treeac4227dab5658c31be479fb1bd4a7600ca755e91 /gnu/packages/hurd.scm
parent7af52bd58c834f46e54f27592b6193604f7119fb (diff)
downloadguix-patches-0193c004322821409e7130f601c0ece676b32665.tar
guix-patches-0193c004322821409e7130f601c0ece676b32665.tar.gz
gnu: Add GNU Mach headers.
* gnu/packages/hurd.scm: New file * gnu-system.am (GNU_SYSTEM_MODULES): Add hurd.scm Co-authored-by: Ludovic Courtès <ludo@gnu.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm57
1 files changed, 57 insertions, 0 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
new file mode 100644
index 0000000000..f915eda9cb
--- /dev/null
+++ b/gnu/packages/hurd.scm
@@ -0,0 +1,57 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2014 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages hurd)
+ #:use-module (guix licenses)
+ #:use-module (guix download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system gnu))
+
+(define-public gnumach-headers
+ (package
+ (name "gnumach-headers")
+ (version "1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnumach/gnumach-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0r371wsm7imx356p0xsls5hifb1gf9y90rm1phr0qkahbmfk9hlv"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-replace
+ 'install
+ (lambda _
+ (zero?
+ (system* "make" "install-data")))
+ (alist-delete
+ 'build
+ %standard-phases))
+
+ ;; GNU Mach supports only IA32 currently, so cheat so that we can at
+ ;; least install its headers.
+ #:configure-flags '("--build=i686-pc-gnu")
+
+ #:tests? #f))
+ (home-page "https://www.gnu.org/software/hurd/microkernel/mach/gnumach.html")
+ (synopsis "GNU Mach kernel headers")
+ (description
+ "Headers of the GNU Mach kernel.")
+ (license gpl2+)))