summaryrefslogtreecommitdiff
path: root/gnu/packages/hexedit.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/hexedit.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/hexedit.scm')
-rw-r--r--gnu/packages/hexedit.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index e5ea18cde6..20f3cbfe7b 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -60,11 +60,9 @@
"/share/man/man1/hexedit.1.gz\"")))
#t)))))
(native-inputs
- `(("autoconf" ,autoconf)
- ("automake" ,automake)))
+ (list autoconf automake))
(inputs
- `(("man-db" ,man-db)
- ("ncurses" ,ncurses)))
+ (list man-db ncurses))
(synopsis "View and edit files or devices in hexadecimal or ASCII")
(description "hexedit shows a file both in ASCII and in hexadecimal. The
file can be a device as the file is read a piece at a time. You can modify
@@ -86,8 +84,7 @@ the file and search through it.")
"0w2xnw3z9ws9qrdpb80q55h6ynhh3aziixcfn45x91bzrbifix9i"))))
(build-system gnu-build-system)
(inputs
- `(("lzo" ,lzo)
- ("ncurses" ,ncurses)))
+ (list lzo ncurses))
(synopsis "Viewer, editor, and analyzer for executable binaries")
(description
"ht is a terminal-based program to view, edit, and analyze any file, but
@@ -112,7 +109,7 @@ Development Environment} (IDE).")
(build-system gnu-build-system)
(arguments '(#:tests? #f)) ; no check target
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(synopsis "Binary file editor")
(description "@command{bvi} is a display-oriented editor for binary files,
based on the @command{vi} text editor.")