summaryrefslogtreecommitdiff
path: root/gnu/packages/hexedit.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 15:42:03 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-04 15:59:08 +0200
commit0136fbd167c38ef476baf1fea9354da5248c4a69 (patch)
tree08d1cb15fcd3917da1ce8adfbdea98e1da9949c7 /gnu/packages/hexedit.scm
parent4fab0da09651344959803015edf01adc2473354e (diff)
downloadguix-patches-0136fbd167c38ef476baf1fea9354da5248c4a69.tar
guix-patches-0136fbd167c38ef476baf1fea9354da5248c4a69.tar.gz
gnu: hexedit: Update to 1.4.2.
* gnu/packages/hexedit.scm (hexedit): Update to 1.4.2. [source]: Use the author's more up-to-date git repository. [native-inputs]: Add autoconf and automake.
Diffstat (limited to 'gnu/packages/hexedit.scm')
-rw-r--r--gnu/packages/hexedit.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 88dbfb234d..9aea8e8700 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -1,6 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Kei Kebreau <kkebreau@posteo.net>
;;; Copyright © 2017 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -21,25 +22,33 @@
#:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (gnu packages)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages ncurses)
#:use-module (guix download)
+ #:use-module (guix git-download)
#:use-module (guix build-system gnu))
(define-public hexedit
(package
(name "hexedit")
- (version "1.2.13")
+ (version "1.4.2")
(source (origin
- (method url-fetch)
- (uri (string-append "http://rigaux.org/"
- name "-" version ".src.tgz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pixel/hexedit.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1mwdp1ikk64cqmagnrrps5jkn3li3n47maiqh2qc1xbp1ains4ka"))))
+ "1xsxa5mip892jkvz9jshj73y6c7j3mgp8y393ciihqlyf2nmfs67"))))
(build-system gnu-build-system)
- (arguments '(#:tests? #f)) ; no check target
- (inputs `(("ncurses" ,ncurses)))
+ (arguments '(#:tests? #f)) ; no check target
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)))
+ (inputs
+ `(("ncurses" ,ncurses)))
(synopsis "View and edit files or devices in hexadecimal or ASCII")
(description "hexedit shows a file both in ASCII and in hexadecimal. The
file can be a device as the file is read a piece at a time. You can modify