summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-09-15 13:26:40 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-10-08 09:13:51 +0200
commitf9250b47d58540516ac3817568e9e475f976ec8f (patch)
tree4f2c57a9de0ba684179e309bb3fc4aa664a67ea9 /gnu/packages/haskell.scm
parentfe56213027d9828c61fa06211458a23f32431e0b (diff)
downloadguix-patches-f9250b47d58540516ac3817568e9e475f976ec8f.tar
guix-patches-f9250b47d58540516ac3817568e9e475f976ec8f.tar.gz
gnu: ghc-8: Update to 8.10.
* gnu/packages/haskell.scm (ghc-8): Update to 8.10. (ghc-8.8): Rename to just ghc. (ghc-8.10): Dito.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6b134ab1cc..86ed095b8d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -612,14 +612,9 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-;; Versions newer than ghc defined below (i.e. the compiler
-;; haskell-build-system uses) should use ghc-next as their name to
-;; ensure ghc (without version specification) and ghc-* packages are
-;; always compatible. See https://issues.guix.gnu.org/issue/47335.
-
(define-public ghc-8.8
(package (inherit ghc-8.6)
- (name "ghc-next")
+ (name "ghc")
(version "8.8.4")
(source
(origin
@@ -672,7 +667,7 @@ interactive environment for the functional language Haskell.")
(define-public ghc-8.10
(package
(inherit ghc-8.8)
- (name "ghc-next")
+ (name "ghc")
(version "8.10.7")
(source
(origin
@@ -723,7 +718,12 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-(define-public ghc-8 ghc-8.6)
+;; Versions newer than ghc defined below (i.e. the compiler
+;; haskell-build-system uses) should use ghc-next as their name to
+;; ensure ghc (without version specification) and ghc-* packages are
+;; always compatible. See https://issues.guix.gnu.org/issue/47335.
+
+(define-public ghc-8 ghc-8.10)
(define-public ghc ghc-8)