summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-20 07:56:47 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:49 -0400
commitefc55bf6f3d2984dba00fbfa6f10a3e8f9e44146 (patch)
treee8c720ce787581aa46ccfcf5bf0345f5e392e4da /gnu/packages/haskell.scm
parent51c8370385173c1055595c2721b1e70137e7dbd7 (diff)
downloadguix-patches-efc55bf6f3d2984dba00fbfa6f10a3e8f9e44146.tar
guix-patches-efc55bf6f3d2984dba00fbfa6f10a3e8f9e44146.tar.gz
gnu: Add ghc-path.
* gnu/packages/haskell.scm (ghc-path): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index e2a7f20697..9bbf0878c6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11652,6 +11652,45 @@ package provides the @code{Validity} type class, which makes these invariants
explicit by providing a function to check whether the invariants hold.")
(license license:expat)))
+(define-public ghc-path
+ (package
+ (name "ghc-path")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/path/path-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0nayla4k1gb821k8y5b9miflv1bi8f0czf9rqr044nrr2dddi2sb"))))
+ (build-system haskell-build-system)
+ (arguments
+ ;; TODO: There are some Windows-related tests and modules that need to be
+ ;; danced around.
+ `(#:tests? #f
+ #:cabal-revision
+ ("1" "05b1zwx2a893h4h5wvgpc5g5pyx71hfmx409rqisd8s1bq1hn463")))
+ (inputs
+ `(("ghc-aeson" ,ghc-aeson)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-hashable" ,ghc-hashable)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-genvalidity" ,ghc-genvalidity)
+ ("ghc-genvalidity-property" ,ghc-genvalidity-property)
+ ("ghc-hspec" ,ghc-hspec)
+ ("ghc-validity" ,ghc-validity)))
+ (home-page
+ "http://hackage.haskell.org/package/path")
+ (synopsis "Support for well-typed paths")
+ (description "This package introduces a type for paths upholding useful
+invariants.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")