summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:38:24 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitdcc5cf1d415a3629f01f816bbaf6d16373ed1d76 (patch)
tree1575f2a9c90cecc4e9453ebd2c99c6c86f8fe567 /gnu/packages/haskell.scm
parent4f7f06e1a2bcb837ded823ec344e374c627a1e6f (diff)
downloadguix-patches-dcc5cf1d415a3629f01f816bbaf6d16373ed1d76.tar
guix-patches-dcc5cf1d415a3629f01f816bbaf6d16373ed1d76.tar.gz
gnu: Add ghc-socks.
* gnu/packages/haskell.scm (ghc-socks): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d574468cc2..0f5c2ddf86 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6089,6 +6089,27 @@ Ephemeral (Elliptic curve and regular) Diffie Hellman key exchanges, and many
extensions.")
(license bsd-3)))
+(define-public ghc-socks
+ (package
+ (name "ghc-socks")
+ (version "0.5.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "socks/socks-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1nmldlwxqasmg359i2aa3a903gi3lmnlspvf12xk49jrg3mf3dg9"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-cereal" ,ghc-cereal)
+ ("ghc-network" ,ghc-network)))
+ (home-page "http://github.com/vincenthz/hs-socks")
+ (synopsis "SOCKS proxy (version 5) implementation.")
+ (description
+ "This library provides a SOCKS proxy (version 5) implementation.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")