summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorJacob MacDonald <jaccarmac@gmail.com>2019-06-07 06:00:26 -0500
committerLudovic Courtès <ludo@gnu.org>2019-07-02 18:33:51 +0200
commitcbff89d126bf5985cfa4884f543c0908c437ff41 (patch)
tree3cb68065483aceb8529aa591925cee5d7287e4aa /gnu/packages/haskell.scm
parentc473bd1881d5093789b41cb6927ee3a5ed6d0439 (diff)
downloadguix-patches-cbff89d126bf5985cfa4884f543c0908c437ff41.tar
guix-patches-cbff89d126bf5985cfa4884f543c0908c437ff41.tar.gz
gnu: Add ghc-ansi-terminal-0.8.
* gnu/packages/haskell.scm (ghc-ansi-terminal-0.8): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm15
1 files changed, 15 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index f40d92b9f7..a7a8b762c4 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4383,6 +4383,21 @@ allows cursor movement, screen clearing, color output showing or hiding the
cursor, and changing the title.")
(license license:bsd-3)))
+(define-public ghc-ansi-terminal-0.8
+ (package (inherit ghc-ansi-terminal)
+ (name "ghc-ansi-terminal")
+ (version "0.8.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/ansi-terminal/ansi-terminal-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0428gq8m3fdnb7ldcsyk97qcch76hcxbgh2666p6f76fs2qbhg7b"))))))
+
(define-public ghc-vault
(package
(name "ghc-vault")