summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-24 17:58:20 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-24 18:02:43 +0100
commitc75db693713e74a632bafe849de68a87ee7e34eb (patch)
tree5596fe00aab0e7aa7ad41f15c7e3d8ee7d67aa97 /gnu/packages/haskell.scm
parent53de3e74fac862bc07de160e8e226372de213dd1 (diff)
downloadguix-patches-c75db693713e74a632bafe849de68a87ee7e34eb.tar
guix-patches-c75db693713e74a632bafe849de68a87ee7e34eb.tar.gz
gnu: ghc: Really disable test that fails with glibc 2.30 and later.
This follows up commit 2e9c43aa9adac2bd6bcf92373d1cf9f322afa5a3, which was incomplete. Fixes <https://bugs.gnu.org/39358>. * gnu/packages/patches/ghc-testsuite-dlopen-pie.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Also use tabs instead of spaces on surrounding patches. * gnu/packages/haskell.scm (ghc-8.6)[native-inputs]: Add patch for "ghc-testsuite". [arguments]: Remove incomplete workaround for the same issue.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8a332636ba..a11b6995ce 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -19,7 +19,7 @@
;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
-;;; Copyright © Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -568,6 +568,7 @@ interactive environment for the functional language Haskell.")
(uri (string-append
"https://www.haskell.org/ghc/dist/"
version "/" name "-" version "-testsuite.tar.xz"))
+ (patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
"0pw9r91g2np3i806g2f4f8z4jfdd7mx226cmdizk4swa7av1qf91"))))
@@ -591,12 +592,6 @@ interactive environment for the functional language Haskell.")
(("^test\\('T8108'") "# guix skipped: test('T8108'"))
(substitute* "libraries/unix/tests/libposix/all.T"
(("^test\\('posix010'") "# guix skipped: test('posix010'"))
- ;; This test attempts to dlopen() a position-independent
- ;; executable(!), which is disallowed since glibc 2.30. See
- ;; https://sourceware.org/bugzilla/show_bug.cgi?id=24323
- (substitute* "testsuite/tests/dynlibs/Makefile"
- (("\\./T13702a")
- "# ./T13702a"))
#t))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")