summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:32:30 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitc3cb9fa67cde6e2adaf404e3caacafc9aa628d41 (patch)
tree0cf27e986293b56a29273ae5b052635b540832f1 /gnu/packages/haskell.scm
parentb12d4f23e07a16e0ebb4be1ecda0adc0f55501aa (diff)
downloadguix-patches-c3cb9fa67cde6e2adaf404e3caacafc9aa628d41.tar
guix-patches-c3cb9fa67cde6e2adaf404e3caacafc9aa628d41.tar.gz
gnu: Add ghc-http-client.
* gnu/packages/haskell.scm (ghc-http-client): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2ed96342d5..fcd4ccb795 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5653,6 +5653,47 @@ described in @url{http://www.lua.org/}.")
"This library provides basic MIME type handling types and functions.")
(license expat)))
+(define-public ghc-http-client
+ (package
+ (name "ghc-http-client")
+ (version "0.4.24")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "http-client/http-client-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0xz133kdfiyy2rm6z95bmvjj6y2540xzd86cfmdv9s6kz4p1ir4k"))))
+ (build-system haskell-build-system)
+ ;; Tests require access to the web.
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("ghc-text" ,ghc-text)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-blaze-builder" ,ghc-blaze-builder)
+ ("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-network" ,ghc-network)
+ ("ghc-streaming-commons" ,ghc-streaming-commons)
+ ("ghc-case-insensitive" ,ghc-case-insensitive)
+ ("ghc-base64-bytestring" ,ghc-base64-bytestring)
+ ("ghc-cookie" ,ghc-cookie)
+ ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-random" ,ghc-random)
+ ("ghc-mime-types" ,ghc-mime-types)
+ ("ghc-network-uri" ,ghc-network-uri)
+ ("ghc-monad-control" ,ghc-monad-control)
+ ("ghc-zlib" ,ghc-zlib)
+ ("ghc-async" ,ghc-async)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/snoyberg/http-client")
+ (synopsis "HTTP client engine")
+ (description
+ "This package provides an HTTP client engine, intended as a base layer
+for more user-friendly packages.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")