summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:39:06 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commitac2607a0cef65e8c0faa5205e734244e1f45bb4a (patch)
tree3d1bde73c881bdbcb761a7725ed591ef6ec79c1a /gnu/packages/haskell.scm
parent86dd2ce0b279e0cca2a81e0650f520f346dfa449 (diff)
downloadguix-patches-ac2607a0cef65e8c0faa5205e734244e1f45bb4a.tar
guix-patches-ac2607a0cef65e8c0faa5205e734244e1f45bb4a.tar.gz
gnu: Add ghc-http-client-tls.
* gnu/packages/haskell.scm (ghc-http-client-tls): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ef1bbe28b6..0bd822f010 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6141,6 +6141,38 @@ needs. It provides a very simple API to create sockets to a destination with
the choice of SSL/TLS, and SOCKS.")
(license bsd-3)))
+(define-public ghc-http-client-tls
+ (package
+ (name "ghc-http-client-tls")
+ (version "0.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "http-client-tls/http-client-tls-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0a01r05h5fxswyn6k6cgqgak4scqjan72hyy5wbdqzzhl4rmh7j5"))))
+ (build-system haskell-build-system)
+ ;; Tests require Internet access
+ (arguments `(#:tests? #f))
+ (propagated-inputs
+ `(("ghc-data-default-class" ,ghc-data-default-class)
+ ("ghc-http-client" ,ghc-http-client)
+ ("ghc-connection" ,ghc-connection)
+ ("ghc-network" ,ghc-network)
+ ("ghc-tls" ,ghc-tls)
+ ("ghc-http-types" ,ghc-http-types)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)))
+ (home-page "https://github.com/snoyberg/http-client")
+ (synopsis "Backend for http-client using the TLS library")
+ (description
+ "This package provides a backend for the http-client package using the
+connection and TLS libraries. It is intended for use by higher-level
+libraries, such as http-conduit.")
+ (license expat)))
+
(define-public idris
(package
(name "idris")