summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:05:32 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commita54d11b58fe50559e95cc22f7771239b5cdd8b00 (patch)
tree9246a850334708ebac3d68442658876502c01b1c /gnu/packages/haskell.scm
parentef2861b1d977add1363474d9dce2db992899a969 (diff)
downloadguix-patches-a54d11b58fe50559e95cc22f7771239b5cdd8b00.tar
guix-patches-a54d11b58fe50559e95cc22f7771239b5cdd8b00.tar.gz
gnu: Add ghc-regex-pcre-builtin.
* gnu/packages/haskell.scm (ghc-regex-pcre-builtin): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index c97dd006d8..eae192433c 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5034,6 +5034,29 @@ markup formats). The TeX reader supports basic LaTeX and AMS extensions, and
it can parse and apply LaTeX macros.")
(license gpl2+)))
+(define-public ghc-regex-pcre-builtin
+ (package
+ (name "ghc-regex-pcre-builtin")
+ (version "0.94.4.8.8.35")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "regex-pcre-builtin/regex-pcre-builtin-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0y7as9wqlkykpipka2cfdhmcnin345q01pp0wsva8fwmvsavdl8b"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-regex-base" ,ghc-regex-base)))
+ (home-page "http://hackage.haskell.org/package/regex-pcre")
+ (synopsis "Enhancement of the builtin Text.Regex library")
+ (description
+ "This package is an enhancement of the @code{Text.Regex} library,
+providing the PCRE backend to accompany regex-base, with bundled code from
+@url{http://www.pcre.org}.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")