summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <othacehe@gnu.org>2021-10-12 16:50:47 +0000
committerMathieu Othacehe <othacehe@gnu.org>2021-10-12 17:46:23 +0000
commita1eca979fb8da842e73c42f4f53be29b169810f2 (patch)
tree681c7283e412bb8a29c2531c4408b49c3e184764 /gnu/packages/haskell.scm
parent48d86a9ec6d8d2e97da2299ea41a03ef4cdaab83 (diff)
parent371aa5777a3805a3886f3feea5f1960fe3fe4219 (diff)
downloadguix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar
guix-patches-a1eca979fb8da842e73c42f4f53be29b169810f2.tar.gz
Merge remote-tracking branch 'origin/master' into core-updates-frozen.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm26
1 files changed, 17 insertions, 9 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 32691b608e..35c836317a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -611,14 +611,9 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-;; Versions newer than ghc defined below (i.e. the compiler
-;; haskell-build-system uses) should use ghc-next as their name to
-;; ensure ghc (without version specification) and ghc-* packages are
-;; always compatible. See https://issues.guix.gnu.org/issue/47335.
-
(define-public ghc-8.8
(package (inherit ghc-8.6)
- (name "ghc-next")
+ (name "ghc")
(version "8.8.4")
(source
(origin
@@ -671,7 +666,7 @@ interactive environment for the functional language Haskell.")
(define-public ghc-8.10
(package
(inherit ghc-8.8)
- (name "ghc-next")
+ (name "ghc")
(version "8.10.7")
(source
(origin
@@ -714,7 +709,15 @@ interactive environment for the functional language Haskell.")
(substitute* '("testsuite/tests/driver/T16521/all.T")
(("extra_files" all) (string-append "[" all))
(("\\]\\), " all)
- (string-append all "expect_broken(0)], ")))))))))
+ (string-append all "expect_broken(0)], ")))))
+ ;; TODO: Turn this into an undconditional patch on the next rebuild.
+ ,@(if (string=? "i686-linux" (%current-system))
+ '((add-after 'skip-more-tests 'skip-failing-tests-i686
+ (lambda _
+ (substitute* '("testsuite/tests/codeGen/should_compile/all.T")
+ (("(test\\('T15155l', )when\\(unregisterised\\(\\), skip\\)" all before)
+ (string-append before "when(arch('i386'), skip)"))))))
+ '())))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")
(files (list
@@ -722,7 +725,12 @@ interactive environment for the functional language Haskell.")
(file-pattern ".*\\.conf\\.d$")
(file-type 'directory))))))
-(define-public ghc-8 ghc-8.6)
+;; Versions newer than ghc defined below (i.e. the compiler
+;; haskell-build-system uses) should use ghc-next as their name to
+;; ensure ghc (without version specification) and ghc-* packages are
+;; always compatible. See https://issues.guix.gnu.org/issue/47335.
+
+(define-public ghc-8 ghc-8.10)
(define-public ghc ghc-8)