summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-23 16:32:44 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-23 16:32:44 +0100
commita057b88124a1b6b6401a2d0c502afc352a10b448 (patch)
tree776b2f4fd2ab654c4a95951555c891195cccbcf5 /gnu/packages/haskell.scm
parentd19b14c8349ce8cacb62619ab68953265daeeca7 (diff)
downloadguix-patches-a057b88124a1b6b6401a2d0c502afc352a10b448.tar
guix-patches-a057b88124a1b6b6401a2d0c502afc352a10b448.tar.gz
gnu: ghc@8.4: Remove redundant inputs.
Incidentally, this fixes a build failure where GHC's build processes fail to link libffi and libgmp for 'ghc-cabal'. * gnu/packages/haskell.scm (ghc-8.4)[inputs]: Remove BINUTILS, GCC, and MAKE-LD-WRAPPER. [arguments]: Adjust accordingly.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm14
1 files changed, 4 insertions, 10 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 8db650e6ae..cafc3e5376 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -37,10 +37,8 @@
(define-module (gnu packages haskell)
#:use-module (gnu packages)
- #:use-module (gnu packages base)
#:use-module (gnu packages bootstrap)
#:use-module (gnu packages elf)
- #:use-module (gnu packages gcc)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages libffi)
#:use-module (gnu packages lisp)
@@ -435,11 +433,7 @@ interactive environment for the functional language Haskell.")
(inputs
`(("gmp" ,gmp)
("ncurses" ,ncurses)
- ("libffi" ,libffi)
- ("target-binutils" ,binutils)
- ("target-gcc" ,gcc)
- ("target-ld-wrapper" ,(make-ld-wrapper "ld-wrapper"
- #:binutils binutils))))
+ ("libffi" ,libffi)))
(native-inputs
`(("perl" ,perl)
("python" ,python) ; for tests
@@ -514,9 +508,9 @@ interactive environment for the functional language Haskell.")
;; plain command names.
(add-before 'configure 'set-target-programs
(lambda* (#:key inputs #:allow-other-keys)
- (let ((binutils (assoc-ref inputs "target-binutils"))
- (gcc (assoc-ref inputs "target-gcc"))
- (ld-wrapper (assoc-ref inputs "target-ld-wrapper")))
+ (let ((binutils (assoc-ref inputs "binutils"))
+ (gcc (assoc-ref inputs "gcc"))
+ (ld-wrapper (assoc-ref inputs "ld-wrapper")))
(setenv "CC" (string-append gcc "/bin/gcc"))
(setenv "CXX" (string-append gcc "/bin/g++"))
(setenv "LD" (string-append ld-wrapper "/bin/ld"))