summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-09-09 21:12:41 -0400
committerTimothy Sample <samplet@ngyro.com>2019-09-09 21:21:00 -0400
commit83aa6562173e06e8fafd4857a2e708feabfe56f8 (patch)
tree22bac8b2886446fb36fee39462375915d6f8d088 /gnu/packages/haskell.scm
parente9c784fba145b9e8d8942740bd750e50af7389bd (diff)
downloadguix-patches-83aa6562173e06e8fafd4857a2e708feabfe56f8.tar
guix-patches-83aa6562173e06e8fafd4857a2e708feabfe56f8.tar.gz
gnu: ghc@8.6: Add missing 'native-search-paths'.
Fixes <https://bugs.gnu.org/37064>. * gnu/packages/haskell.scm (ghc-8.6)[native-search-paths]: Set search paths explicitly instead of inheriting them.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 4d16cd656f..d86daa52c5 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -596,7 +596,13 @@ interactive environment for the functional language Haskell.")
(("^test\\('T8108'") "# guix skipped: test('T8108'"))
(substitute* "libraries/unix/tests/libposix/all.T"
(("^test\\('posix010'") "# guix skipped: test('posix010'"))
- #t))))))))
+ #t))))))
+ (native-search-paths (list (search-path-specification
+ (variable "GHC_PACKAGE_PATH")
+ (files (list
+ (string-append "lib/ghc-" version)))
+ (file-pattern ".*\\.conf\\.d$")
+ (file-type 'directory))))))
(define-public ghc-8 ghc-8.4)