summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-26 17:07:55 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:50 +0100
commit74d9f72e02bb3d94960f8a4ba9563313e74094f0 (patch)
treee28e4566a927bab5375e3391094a44980de50b6f /gnu/packages/haskell.scm
parent5de6eedc603f83217ae947fd364d80412621e3ed (diff)
downloadguix-patches-74d9f72e02bb3d94960f8a4ba9563313e74094f0.tar
guix-patches-74d9f72e02bb3d94960f8a4ba9563313e74094f0.tar.gz
gnu: Add ghc-packedstring.
* gnu/packages/haskell.scm (ghc-packedstring): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 851d961b5d..f84a089899 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5185,6 +5185,35 @@ within an enclosed computation, while remaining responsive to (external)
asynchronous exceptions.")
(license expat)))
+(define-public ghc-packedstring
+ (package
+ (name "ghc-packedstring")
+ (version "0.1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "packedstring/packedstring-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1x78pzzdlnpcmh9p37rlf8m5cxf3yqm2alf3whl4zpr9w25r0qj8"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'enable-extension
+ (lambda _
+ ;; This package won't compile without the StandaloneDeriving
+ ;; extension.
+ (substitute* "packedstring.cabal"
+ (("CPP") "CPP, StandaloneDeriving"))
+ #t)))))
+ (home-page "http://hackage.haskell.org/package/packedstring")
+ (synopsis "Library for packed strings")
+ (description
+ "This deprecated library provides an implementation of packed strings.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")