summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-07-16 14:43:03 -0400
committerTimothy Sample <samplet@ngyro.com>2019-07-16 14:43:03 -0400
commit71e5d425c9b9e108ebdd06d13de45b56dddd9ef5 (patch)
tree8332eaa475487f230f352d2a2294da6920a5ca9d /gnu/packages/haskell.scm
parent6869b6635afd93872b8f0d9f2db0db4c0d765a86 (diff)
downloadguix-patches-71e5d425c9b9e108ebdd06d13de45b56dddd9ef5.tar
guix-patches-71e5d425c9b9e108ebdd06d13de45b56dddd9ef5.tar.gz
gnu: ghc-clock-bootstrap: Move and inherit from ghc-clock.
Fixes <https://bugs.gnu.org/36084>. * gnu/packages/haskell-check.scm (ghc-clock-bootstrap): Move this... * gnu/packages/haskell.scm (ghc-clock-bootstrap): ...here and inherit from ghc-clock (which implies updating to version 0.7.2). Co-authored-by: Robert Vollmert <rob@vllmrt.net>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 17fddc1965..a30b4376eb 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -4928,6 +4928,16 @@ unbounded @code{Integer} type.")
timer functions of different operating systems via a unified API.")
(license license:bsd-3)))
+;; This package builds `clock` without tests, since the tests rely on tasty
+;; and tasty-quickcheck, which in turn require clock to build.
+(define-public ghc-clock-bootstrap
+ (package
+ (inherit ghc-clock)
+ (name "ghc-clock-bootstrap")
+ (arguments '(#:tests? #f))
+ (inputs '())
+ (properties '((hidden? #t)))))
+
(define-public ghc-charset
(package
(name "ghc-charset")