summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-21 03:44:39 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:50 -0400
commit697cae2a67ae65ed7e14bf3cdf1e76d4c7579639 (patch)
treea64931eb25a5060336c3a0640391348302ed23a1 /gnu/packages/haskell.scm
parenta60056b5d309c76c0d88a962f106a158c1b38914 (diff)
downloadguix-patches-697cae2a67ae65ed7e14bf3cdf1e76d4c7579639.tar
guix-patches-697cae2a67ae65ed7e14bf3cdf1e76d4c7579639.tar.gz
gnu: Add ghc-exactprint.
* gnu/packages/haskell.scm (ghc-exactprint): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index fe860fb81f..c7056a262a 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11759,6 +11759,38 @@ files/directories, and more.")
and parsers with useful semantics.")
(license license:bsd-3)))
+(define-public ghc-exactprint
+ (package
+ (name "ghc-exactprint")
+ (version "0.5.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/"
+ "ghc-exactprint/ghc-exactprint-" version ".tar.gz"))
+ (sha256
+ (base32
+ "141k6qiys0m0r4br7ikp4i546vs3xcil9cwglzcdfcbnb5nj1z87"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-paths" ,ghc-paths)
+ ("ghc-syb" ,ghc-syb)
+ ("ghc-free" ,ghc-free)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-diff" ,ghc-diff)
+ ("ghc-silently" ,ghc-silently)
+ ("ghc-filemanip" ,ghc-filemanip)))
+ (home-page
+ "http://hackage.haskell.org/package/ghc-exactprint")
+ (synopsis "ExactPrint for GHC")
+ (description
+ "Using the API Annotations available from GHC 7.10.2, this library
+provides a means to round-trip any code that can be compiled by GHC, currently
+excluding @file{.lhs} files.")
+ (license license:bsd-3)))
+
(define-public ghc-stylish-haskell
(package
(name "ghc-stylish-haskell")