summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorAlex Vong <alexvong1995@gmail.com>2018-10-18 02:53:32 +0800
committerLudovic Courtès <ludo@gnu.org>2018-10-19 23:11:07 +0200
commit58352f269e46942c34d7ee4e29f91144576ca661 (patch)
tree7a87dc31cee1bae17fa587a9c697c6b55d2468a0 /gnu/packages/haskell.scm
parentbe200ef316478585059041a33d8f4287017dea5a (diff)
downloadguix-patches-58352f269e46942c34d7ee4e29f91144576ca661.tar
guix-patches-58352f269e46942c34d7ee4e29f91144576ca661.tar.gz
build-system/haskell: Use 'strip-store-file-name'.
See the discussion at <https://lists.gnu.org/archive/html/guix-devel/2018-10/msg00250.html>. * guix/build/haskell-build-system.scm (package-name-version): Remove it. (configure): Use 'strip-store-file-name' instead of 'package-name-version'. (setup-compiler): Likewise. (make-ghc-package-database): Likewise. (register): Likewise. * gnu/packages/haskell.scm (ghc-cairo)[arguments]: Likewise. * gnu/packages/agda.scm (agda)[arguments]: Likewise. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 0a90ac523c..57435dca07 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -10619,6 +10619,7 @@ expose it from another module in the hierarchy.
(lambda* (#:key outputs inputs tests? (configure-flags '())
#:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
+ (name-version (strip-store-file-name out))
(input-dirs (match inputs
(((_ . dir) ...)
dir)
@@ -10629,8 +10630,7 @@ expose it from another module in the hierarchy.
`(,(string-append "--bindir=" out "/bin"))
`(,(string-append
"--docdir=" out
- "/share/doc/" ((@@ (guix build haskell-build-system)
- package-name-version) out)))
+ "/share/doc/" name-version))
'("--libsubdir=$compiler/$pkg-$version")
'("--package-db=../package.conf.d")
'("--global")