summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-20 07:56:04 +0200
committerTimothy Sample <samplet@ngyro.com>2019-07-19 23:09:49 -0400
commit522b61ab80ae9fd7696b452c99a16b5b026e8072 (patch)
treef1388fa65596012d00704cb40ce2a3b087dfec81 /gnu/packages/haskell.scm
parentf26f2e757ff206a24bc2a0b49f9bb1c292a0971a (diff)
downloadguix-patches-522b61ab80ae9fd7696b452c99a16b5b026e8072.tar
guix-patches-522b61ab80ae9fd7696b452c99a16b5b026e8072.tar.gz
gnu: Add ghc-genvalidity.
* gnu/packages/haskell.scm (ghc-genvalidity): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 19cd39e690..a9b0dd71ca 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -11563,6 +11563,37 @@ stand for certain ASCII character sequences, i.e. → instead of @code{->},
∀ instead of @code{forall} and many others.")
(license license:bsd-3)))
+(define-public ghc-genvalidity
+ (package
+ (name "ghc-genvalidity")
+ (version "0.5.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/genvalidity/genvalidity-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "17ykq38j9a2lzir6dqz5jgy6ndaafrpkhqhcg96c5ppg7wcxaaj0"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)
+ ("ghc-validity" ,ghc-validity)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("hspec-discover" ,hspec-discover)
+ ("ghc-hspec-core" ,ghc-hspec-core)))
+ (home-page
+ "https://github.com/NorfairKing/validity")
+ (synopsis
+ "Testing utilities for the @code{validity} library")
+ (description
+ "This package provides testing utilities that are useful in conjunction
+with the @code{Validity} typeclass.")
+ (license license:expat)))
+
(define-public ghc-validity
(package
(name "ghc-validity")