summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-11-27 13:33:12 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-12-10 14:34:51 +0100
commit45813e67e0bac985f351bbae8f279f7d4ae84aa0 (patch)
tree54bae3b5c9fb3ef947df09e656edb68cc2e8dffb /gnu/packages/haskell.scm
parent51c05fcf206ff5be99026eb2d0cfb5a9e70098c3 (diff)
downloadguix-patches-45813e67e0bac985f351bbae8f279f7d4ae84aa0.tar
guix-patches-45813e67e0bac985f351bbae8f279f7d4ae84aa0.tar.gz
gnu: Add ghc-hourglass.
* gnu/packages/haskell.scm (ghc-hourglass): New variable.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 2db27a4a3b..e6158b2d9f 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -5714,6 +5714,35 @@ The use case of this class is abstracting manipulation of types that are just
wrapping a bytestring with stronger and more meaniful name.")
(license bsd-3)))
+(define-public ghc-hourglass
+ (package
+ (name "ghc-hourglass")
+ (version "0.2.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://hackage.haskell.org/package/"
+ "hourglass/hourglass-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1xha17nwzxdjizbcp63d2142c6q051y77facs7xribgcl5iz2m4v"))))
+ (build-system haskell-build-system)
+ (propagated-inputs
+ `(("ghc-mtl" ,ghc-mtl)
+ ("ghc-old-locale" ,ghc-old-locale)))
+ (native-inputs
+ `(("ghc-tasty" ,ghc-tasty)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ (home-page "https://github.com/vincenthz/hs-hourglass")
+ (synopsis "Simple time-related library for Haskell")
+ (description
+ "This is a simple time library providing a simple but powerful and
+performant API. The backbone of the library are the @code{Timeable} and
+@code{Time} type classes. Each @code{Timeable} instances can be converted to
+a type that has a @code{Time} instances, and thus are different
+representations of current time.")
+ (license bsd-3)))
+
(define-public idris
(package
(name "idris")