summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorRobert Vollmert <rob@vllmrt.net>2019-05-28 21:10:24 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-02 01:38:36 +0200
commit3eb261e2e54fe379071f47812bc52cc4b5b5e6c6 (patch)
tree57e23969e7d6398be9c6400f7f47fa119e6f64d8 /gnu/packages/haskell.scm
parent8b3560501ff32ba09dafa053a4faed6ad56726e3 (diff)
downloadguix-patches-3eb261e2e54fe379071f47812bc52cc4b5b5e6c6.tar
guix-patches-3eb261e2e54fe379071f47812bc52cc4b5b5e6c6.tar.gz
gnu: ghc-happy: Skip memory-hungry tests.
Tests fail reliably for me on a system with 2GB of available RAM, in `issue93.a.hs` and `issue93.n.hs`. * gnu/packages/haskell.scm (ghc-happy): Skip test "issue93". Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 33c9c6484d..822b0499b6 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1325,6 +1325,16 @@ postfix notation. For more information on stack based languages, see
(base32
"138xpxdb7x62lpmgmb6b3v3vgdqqvqn4273jaap3mjmc2gla709y"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'skip-test-issue93
+ (lambda _
+ ;; Tests run out of memory on a system with 2GB of available RAM,
+ ;; in 'issue93.a.hs' and 'issue93.n.hs'.
+ (substitute* "tests/Makefile"
+ ((" issue93.y ") " "))
+ #t)))))
(home-page "https://hackage.haskell.org/package/happy")
(synopsis "Parser generator for Haskell")
(description "Happy is a parser generator for Haskell. Given a grammar