summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-23 19:42:56 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-23 19:42:56 +0100
commit2e9c43aa9adac2bd6bcf92373d1cf9f322afa5a3 (patch)
tree07dcdcb0fd6940c56c158fe03b1b3dcc3ba3a882 /gnu/packages/haskell.scm
parentc711b6abdb7fc740b37e95596eab2b1b9aba0e1d (diff)
downloadguix-patches-2e9c43aa9adac2bd6bcf92373d1cf9f322afa5a3.tar
guix-patches-2e9c43aa9adac2bd6bcf92373d1cf9f322afa5a3.tar.gz
gnu: GHC: Disable test that fails with glibc 2.30 and later.
Fixes <https://bugs.gnu.org/39358>. * gnu/packages/haskell.scm (ghc-8.6)[arguments]: Add substitution to disable broken test.
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 9 insertions, 2 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 6e9cfc6a9e..8a332636ba 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2018, 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
+;;; Copyright © Marius Bakke <mbakke@fastmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -582,14 +583,20 @@ interactive environment for the functional language Haskell.")
,make-flags))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
- ;; These two tests refer to the root user, which doesn't exist
- ;; (see <https://bugs.gnu.org/36692>).
(add-after 'unpack-testsuite 'skip-tests
(lambda _
+ ;; These two tests refer to the root user, which doesn't exist
+ ;; (see <https://bugs.gnu.org/36692>).
(substitute* "libraries/unix/tests/all.T"
(("^test\\('T8108'") "# guix skipped: test('T8108'"))
(substitute* "libraries/unix/tests/libposix/all.T"
(("^test\\('posix010'") "# guix skipped: test('posix010'"))
+ ;; This test attempts to dlopen() a position-independent
+ ;; executable(!), which is disallowed since glibc 2.30. See
+ ;; https://sourceware.org/bugzilla/show_bug.cgi?id=24323
+ (substitute* "testsuite/tests/dynlibs/Makefile"
+ (("\\./T13702a")
+ "# ./T13702a"))
#t))))))
(native-search-paths (list (search-path-specification
(variable "GHC_PACKAGE_PATH")