summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell.scm
diff options
context:
space:
mode:
authorMatthew James Kraai <kraai@ftbfs.org>2021-07-13 05:09:37 -0700
committerLudovic Courtès <ludo@gnu.org>2021-07-26 19:42:49 +0200
commit0a1ea2b0fb9f486c0e56320b92f3dd4a95c7ff1c (patch)
treee8d35bc1609f8beb29e875a53875afdc6ed6c606 /gnu/packages/haskell.scm
parent599b173b11cc29b77f7463566ef6168f7e34b510 (diff)
downloadguix-patches-0a1ea2b0fb9f486c0e56320b92f3dd4a95c7ff1c.tar
guix-patches-0a1ea2b0fb9f486c0e56320b92f3dd4a95c7ff1c.tar.gz
gnu: ghc-8.8: Update to 8.8.4.
* gnu/packages/haskell.scm (ghc-8.8): Update to 8.8.4. [arguments]: Add 'fix-cc-reference phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/haskell.scm')
-rw-r--r--gnu/packages/haskell.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 09732fc594..3d10bdc946 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -20,6 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2021 Matthew James Kraai <kraai@ftbfs.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -613,14 +614,14 @@ interactive environment for the functional language Haskell.")
(define-public ghc-8.8
(package (inherit ghc-8.6)
(name "ghc")
- (version "8.8.3")
+ (version "8.8.4")
(source
(origin
(method url-fetch)
(uri (string-append "https://www.haskell.org/ghc/dist/"
version "/ghc-" version "-src.tar.xz"))
(sha256
- (base32 "128g932i3wix6ic03v04nh5755vyjiidzri9iybwad72yfmc1p70"))))
+ (base32 "0bgwbxxvdn56l91bp9p5d083gzcfdi6z8l8b17qzjpr3n8w5wl7h"))))
(native-inputs
`(("ghc-bootstrap" ,ghc-8.6)
("ghc-testsuite"
@@ -632,7 +633,7 @@ interactive environment for the functional language Haskell.")
(patches (search-patches "ghc-testsuite-dlopen-pie.patch"))
(sha256
(base32
- "1l32mp94ll72skfsq1g2fqax4bkiw8b85gr3wd0bbqsqyi9a9jpr"))))
+ "0c55pj2820q26rikhpf636sn4mjgqsxjrl94vsywrh79dxp3k14z"))))
("git" ,git) ; invoked during tests
,@(filter (match-lambda
(("ghc-bootstrap" . _) #f)
@@ -643,6 +644,11 @@ interactive environment for the functional language Haskell.")
(substitute-keyword-arguments (package-arguments ghc-8.6)
((#:phases phases '%standard-phases)
`(modify-phases ,phases
+ (add-after 'fix-references 'fix-cc-reference
+ (lambda _
+ (substitute* "utils/hsc2hs/Common.hs"
+ (("\"cc\"") "\"gcc\""))
+ #t))
(add-after 'unpack-testsuite 'skip-more-tests
(lambda _
;; XXX: This test fails because our ld-wrapper script