summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-11-13 23:59:23 -0800
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:50 -0500
commitf2ed1e6d5240d25ed78fc61c2a2e0c574d689acf (patch)
treee0740e8dc8e4435f1b9b6c55868f429159474582 /gnu/packages/haskell-xyz.scm
parenteef308d62a488fe56344ba8f7949217fb8cba427 (diff)
downloadguix-patches-f2ed1e6d5240d25ed78fc61c2a2e0c574d689acf.tar
guix-patches-f2ed1e6d5240d25ed78fc61c2a2e0c574d689acf.tar.gz
gnu: Add ghc-alsa-mixer.
* gnu/packages/haskell-xyz.scm (ghc-alsa-mixer): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index c20af47b3e..e21235163a 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -304,6 +304,29 @@ tool lex or flex for C/C++.")
needed by both alsa-seq and alsa-pcm.")
(license license:bsd-3)))
+(define-public ghc-alsa-mixer
+ (package
+ (name "ghc-alsa-mixer")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri
+ (string-append
+ "mirror://hackage/package/alsa-mixer/alsa-mixer-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00ny2p3276jilidjs44npc8zmbhynz3f2lpmlwwl6swwx5yijsnb"))))
+ (build-system haskell-build-system)
+ (inputs `(("ghc-alsa-core" ,ghc-alsa-core)))
+ (native-inputs `(("ghc-c2hs" ,ghc-c2hs)))
+ (home-page "https://github.com/ttuegel/alsa-mixer")
+ (synopsis "Bindings to the ALSA simple mixer API")
+ (description
+ "This package provides bindings to the ALSA simple mixer API.")
+ (license license:bsd-3)))
+
(define-public ghc-annotated-wl-pprint
(package
(name "ghc-annotated-wl-pprint")