summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/haskell-xyz.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 13 insertions, 17 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e49e9d2f35..f5d15bcc2f 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -11371,10 +11371,8 @@ semigroup.")
(inherit ghc-semigroups)
(name "ghc-semigroups-bootstrap")
(inputs
- `(("ghc-nats" ,ghc-nats-bootstrap)
- ("ghc-tagged" ,ghc-tagged)
- ("ghc-unordered-containers" ,ghc-unordered-containers-bootstrap)
- ("ghc-hashable" ,ghc-hashable-bootstrap)))
+ (list ghc-nats-bootstrap ghc-tagged
+ ghc-unordered-containers-bootstrap ghc-hashable-bootstrap))
(properties '((hidden? #t)))))
(define-public ghc-serialise
@@ -11824,16 +11822,16 @@ mainstream languages.")
"0das5n44dhlcv5i233iakx37d17kidqvhrvp6w9nd7hc015ry026"))))
(build-system haskell-build-system)
(native-inputs
- `(("ghc-async" ,ghc-async)
- ("ghc-base-compat-batteries" ,ghc-base-compat-batteries)
- ("ghc-base-compat" ,ghc-base-compat)
- ("ghc-hunit" ,ghc-hunit)
- ("ghc-math-functions" ,ghc-math-functions)
- ("ghc-random" ,ghc-random-bootstrap)
- ("ghc-test-framework" ,ghc-test-framework)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
- ("ghc-tf-random" ,ghc-tf-random)
- ("ghc-vector" ,ghc-vector)))
+ (list ghc-async
+ ghc-base-compat-batteries
+ ghc-base-compat
+ ghc-hunit
+ ghc-math-functions
+ ghc-random-bootstrap
+ ghc-test-framework
+ ghc-test-framework-hunit
+ ghc-tf-random
+ ghc-vector))
(home-page "https://hackage.haskell.org/package/splitmix")
(synopsis "Fast and splittable pseudorandom number generator")
(description "This package provides a Pure Haskell implementation of the
@@ -14328,9 +14326,7 @@ widths to the Char type.")
(inherit ghc-wcwidth)
(name "ghc-wcwidth-bootstrap")
(inputs
- `(("ghc-setlocale" ,ghc-setlocale)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-attoparsec" ,ghc-attoparsec-bootstrap)))
+ (list ghc-setlocale ghc-utf8-string ghc-attoparsec-bootstrap))
(properties '((hidden? #t)))))
(define-public ghc-weigh