summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2020-06-09 14:04:50 +0200
committerMarius Bakke <marius@gnu.org>2020-06-14 23:15:21 +0200
commitddd798364838e5a0083fd65037164e1a92568133 (patch)
tree9af74a36320a4ff5e48959a6218e546698d8668d /gnu/packages/haskell-xyz.scm
parentb1342a82576544fda4777c80267ada7945ae7e4d (diff)
downloadguix-patches-ddd798364838e5a0083fd65037164e1a92568133.tar
guix-patches-ddd798364838e5a0083fd65037164e1a92568133.tar.gz
gnu: Add ghc-regex-pcre.
* gnu/packages/haskell-xyz.scm (ghc-regex-pcre): New public variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 815af82500..6908050afc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10249,6 +10249,29 @@ This is not good for Unicode users. This modified regex-compat uses regex-tdfa
this problem.")
(license license:bsd-3)))
+(define-public ghc-regex-pcre
+ (package
+ (name "ghc-regex-pcre")
+ (version "0.94.4")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "regex-pcre/regex-pcre-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1h16w994g9s62iwkdqa7bar2n9cfixmkzz2rm8svm960qr57valf"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-regex-base" ,ghc-regex-base)
+ ("pcre" ,pcre)))
+ (home-page "https://hackage.haskell.org/package/regex-pcre")
+ (synopsis "Enhancement of the builtin Text.Regex library")
+ (description
+ "This package is an enhancement of the @code{Text.Regex} library.
+It wraps the @code{PCRE} C library providing Perl-compatible regular
+expressions.")
+ (license license:bsd-3)))
+
(define-public ghc-regex-pcre-builtin
(package
(name "ghc-regex-pcre-builtin")