summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:34 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:49 +0100
commitcf4ee324a502eaed687cf5d803e152745d924097 (patch)
treef636ee0ea9249982fcf271fda505ce1a9e21cbfa /gnu/packages/haskell-xyz.scm
parent560d423bdbc800c39b8209e88d5a73be4b5fa751 (diff)
downloadguix-patches-cf4ee324a502eaed687cf5d803e152745d924097.tar
guix-patches-cf4ee324a502eaed687cf5d803e152745d924097.tar.gz
gnu: ghc-aeson-compat: Update to 0.3.10.
* gnu/packages/haskell-xyz.scm (ghc-aeson-compat): Update to 0.3.10. [inputs]: Remove ghc-exceptions, ghc-semigroups, and ghc-nats. [native-inputs]: Add ghc-base-orphans.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm17
1 files changed, 6 insertions, 11 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index aa7e3153da..d87c457380 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -212,7 +212,7 @@ for Haskell.")
(define-public ghc-aeson-compat
(package
(name "ghc-aeson-compat")
- (version "0.3.9")
+ (version "0.3.10")
(source
(origin
(method url-fetch)
@@ -221,30 +221,25 @@ for Haskell.")
"aeson-compat-" version ".tar.gz"))
(sha256
(base32
- "1j13gykv4ryvmr14w5blz0nnpdb4p0hpa27wahw3mhb1lwdr8hz0"))))
+ "0ia3qfdpbrzhwwg4ywpdwca0z1m85k081pcz6jh1sx8qjsvcr71w"))))
(build-system haskell-build-system)
- (arguments
- `(#:cabal-revision
- ("7" "15aflmqs5y0yg2p4042yvnhxyp11ndlihs1dxj21bxfdzd1bbkrn")))
(inputs `(("ghc-base-compat" ,ghc-base-compat)
("ghc-aeson" ,ghc-aeson)
("ghc-attoparsec" ,ghc-attoparsec)
- ("ghc-attoparsec" ,ghc-attoparsec-iso8601)
- ("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-attoparsec-iso8601" ,ghc-attoparsec-iso8601)
("ghc-hashable" ,ghc-hashable)
("ghc-scientific" ,ghc-scientific)
("ghc-time-locale-compat" ,ghc-time-locale-compat)
("ghc-unordered-containers" ,ghc-unordered-containers)
("ghc-vector" ,ghc-vector)
- ("ghc-tagged" ,ghc-tagged)
- ("ghc-semigroups" ,ghc-semigroups)
- ("ghc-nats" ,ghc-nats)))
+ ("ghc-tagged" ,ghc-tagged)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
("ghc-tasty-hunit" ,ghc-tasty-hunit)
("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)))
+ ("ghc-quickcheck-instances" ,ghc-quickcheck-instances)
+ ("ghc-base-orphans" ,ghc-base-orphans)))
(home-page "https://github.com/phadej/aeson-compat")
(synopsis "Compatibility layer for ghc-aeson")
(description "This Haskell package provides compatibility layer for