summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2019-12-29 01:09:05 -0500
committerEfraim Flashner <efraim@flashner.co.il>2019-12-29 09:56:51 +0200
commitbb62932ad81b58c5e06aa864245021242a8f2ff2 (patch)
tree3b67abbb56257f160b27cdc064ecb90cf84d1461 /gnu/packages/haskell-xyz.scm
parente79a07bcc7f1c09eb3deefd611e7f87c082dfd6d (diff)
downloadguix-patches-bb62932ad81b58c5e06aa864245021242a8f2ff2.tar
guix-patches-bb62932ad81b58c5e06aa864245021242a8f2ff2.tar.gz
gnu: Add ghc-filepath-bytestring.
* gnu/packages/haskell-xyz.scm (ghc-filepath-bytestring): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index fb6833207d..716d14d7fb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3998,6 +3998,29 @@ directories. It includes code for pattern matching, finding files, modifying
file contents, and more.")
(license license:bsd-3)))
+(define-public ghc-filepath-bytestring
+ (package
+ (name "ghc-filepath-bytestring")
+ (version "1.4.2.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/filepath-bytestring/"
+ "filepath-bytestring-" version ".tar.gz"))
+ (sha256
+ (base32
+ "06shdskjj391hb9295slm9gg2rbn5fdq5v6fg0mgn3yl5dv8q5dx"))))
+ (build-system haskell-build-system)
+ (native-inputs
+ `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (home-page "http://hackage.haskell.org/package/filepath-bytestring")
+ (synopsis "Library for manipulating RawFilePaths in a cross-platform way")
+ (description "This package provides a drop-in replacement for the standard
+@code{filepath} library, operating on @code{RawFilePath} values rather than
+@code{FilePath} values to get the speed benefits of using @code{ByteStrings}.")
+ (license license:bsd-3)))
+
(define-public ghc-findbin
(package
(name "ghc-findbin")