summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 17:42:53 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:41 -0500
commitb59c35182e5516be5b3f9ded130235de1e7271bb (patch)
treec05e0505bc1133c6ab7fce218aa934be7955a84f /gnu/packages/haskell-xyz.scm
parent8428e92c55653eced5323d4414b0ea17d067ba78 (diff)
downloadguix-patches-b59c35182e5516be5b3f9ded130235de1e7271bb.tar
guix-patches-b59c35182e5516be5b3f9ded130235de1e7271bb.tar.gz
gnu: Add ghc-conduit-zstd.
* gnu/packages/haskell-xyz.scm (ghc-conduit-zstd): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 9115afd0c5..565d613d1c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2141,6 +2141,37 @@ dependencies. The basic idea is that this package should only depend on
@code{haskell-platform} packages and @code{conduit}.")
(license license:expat)))
+(define-public ghc-conduit-zstd
+ (package
+ (name "ghc-conduit-zstd")
+ (version "0.0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "conduit-zstd/conduit-zstd-" version ".tar.gz"))
+ (sha256
+ (base32
+ "04h7w2903hgw4gjcx2pg29yinnmfapawvc19hd3r57rr12fzb0c6"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-conduit" ,ghc-conduit)
+ ("ghc-zstd" ,ghc-zstd)))
+ (native-inputs
+ `(("ghc-hunit" ,ghc-hunit)
+ ("ghc-conduit-combinators" ,ghc-conduit-combinators)
+ ("ghc-conduit-extra" ,ghc-conduit-extra)
+ ("ghc-test-framework" ,ghc-test-framework)
+ ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
+ ("ghc-test-framework-th" ,ghc-test-framework-th)))
+ (home-page "https://github.com/luispedro/conduit-zstd#readme")
+ (synopsis "Conduit-based ZStd Compression")
+ (description "Zstandard compression packaged as a conduit. This is
+a very thin wrapper around the
+@url{https://github.com/facebookexperimental/hs-zstd/, official hs-zstd
+interface}.")
+ (license license:expat)))
+
(define-public ghc-configurator
(package
(name "ghc-configurator")