summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-10-31 19:02:34 -0700
committerChristopher Baines <mail@cbaines.net>2020-11-01 13:34:46 +0000
commitaa8f40097de751737bb5068e8b6cf87b2a2a559f (patch)
treeb213c709e7fde875e9c91f1cdd10be5611cede0e /gnu/packages/haskell-xyz.scm
parent1748f1b80acfb7db872721c60e3e19667e56a85b (diff)
downloadguix-patches-aa8f40097de751737bb5068e8b6cf87b2a2a559f.tar
guix-patches-aa8f40097de751737bb5068e8b6cf87b2a2a559f.tar.gz
gnu: Add ghc-cassava-megaparsec.
* gnu/packages/haskell-xyz.scm (ghc-cassava-megaparsec): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 70303e2f16..03bf9898c5 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -1633,6 +1633,37 @@ very simple example of encoding CSV data:
")
(license license:bsd-3)))
+(define-public ghc-cassava-megaparsec
+ (package
+ (name "ghc-cassava-megaparsec")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/cassava-megaparsec/"
+ "cassava-megaparsec-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "03x1462agrfdagklp8c89b8p4z2hd8nbf6d3895sz770zjkawda7"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-cassava" ,ghc-cassava)
+ ("ghc-megaparsec" ,ghc-megaparsec)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-vector" ,ghc-vector)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hspec-megaparsec" ,ghc-hspec-megaparsec)))
+ (home-page "https://github.com/stackbuilders/cassava-megaparsec")
+ (synopsis "Megaparsec parser for CSV files that plays nicely with Cassava")
+ (description
+ "Alternative parser for the Cassava package written with Megaparsec that
+provides for better error messages at the expense of some speed.")
+ (license license:expat)))
+
(define-public ghc-cborg
(package
(name "ghc-cborg")