summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-13 07:40:38 -0800
committerChristopher Baines <mail@cbaines.net>2020-05-08 09:53:25 +0100
commit8a6e745df12e21705620b59e7adb1ec309366a4c (patch)
tree4ef9bd46ef6309c2e40a26c64ff5d10343d4ff2b /gnu/packages/haskell-xyz.scm
parent4759b61735e0b78de81d59cdcb9474b3321c4bd0 (diff)
downloadguix-patches-8a6e745df12e21705620b59e7adb1ec309366a4c.tar
guix-patches-8a6e745df12e21705620b59e7adb1ec309366a4c.tar.gz
gnu: Add ghc-protolude.
* gnu/packages/haskell-xyz.scm (ghc-protolude): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 05c0524e94..eef1765a71 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9281,6 +9281,33 @@ project-template tries to provide a canonical Haskell library for implementing
the ideal templating system.")
(license license:bsd-3)))
+(define-public ghc-protolude
+ (package
+ (name "ghc-protolude")
+ (version "0.2.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/protolude/protolude-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0zzkyxz0vmcbncpid7gp72fpjj0fla3gqhlfkij5c5lg12skjgfj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-async" ,ghc-async)
+ ("ghc-hashable" ,ghc-hashable)
+ ("ghc-mtl-compat" ,ghc-mtl-compat)
+ ("ghc-transformers-compat" ,ghc-transformers-compat)))
+ (home-page "https://github.com/protolude/protolude")
+ (synopsis "Sensible set of defaults for writing custom Preludes")
+ (description
+ "Protolude gives you sensible defaults for writing custom Preludes to
+replace the standard one provided by GHC.")
+ (license license:expat)))
+
(define-public ghc-psqueues
(package
(name "ghc-psqueues")