summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2020-09-08 22:16:26 -0400
committerTimothy Sample <samplet@ngyro.com>2020-09-08 23:37:34 -0400
commit7f89dfc9d9f6b2c0b9cc1a779b97c05f3a650b26 (patch)
treef0c219a026880134d8db4dab138988032c60d2f6 /gnu/packages/haskell-xyz.scm
parentee7a7c9014f7dd238ab42d15ef3f5f1fe187d1c3 (diff)
downloadguix-patches-7f89dfc9d9f6b2c0b9cc1a779b97c05f3a650b26.tar
guix-patches-7f89dfc9d9f6b2c0b9cc1a779b97c05f3a650b26.tar.gz
gnu: Add ghc-xml-hamlet.
* gnu/packages/haskell-xyz.scm (ghc-xml-hamlet): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 08d6580a32..f4af00283c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -20,7 +20,7 @@
;;; Copyright © 2019 Robert Vollmert <rob@vllmrt.net>
;;; Copyright © 2019 Jacob MacDonald <jaccarmac@gmail.com>
;;; Copyright © 2019,2020 John Soo <jsoo1@asu.edu>
-;;; Copyright © 2019 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2019, 2020 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2019 Alex Griffin <a@ajgrf.com>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2020 JoJo <jo@jo.zone>
@@ -14712,6 +14712,30 @@ the @code{conduit} package.")
documents.")
(license license:expat)))
+(define-public ghc-xml-hamlet
+ (package
+ (name "ghc-xml-hamlet")
+ (version "0.5.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/xml-hamlet/"
+ "xml-hamlet-" version ".tar.gz"))
+ (sha256
+ (base32 "0jrhcjy7ww59dafg857f2g2df1fw2jmbwcs1q379ph0pc5rxj3lj"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-shakespeare" ,ghc-shakespeare)
+ ("ghc-xml-conduit" ,ghc-xml-conduit)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-hunit" ,ghc-hunit)))
+ (home-page "https://www.yesodweb.com/")
+ (synopsis "Hamlet-style quasiquoter for XML content")
+ (description "This package provides a type-safe tool for generating XML
+code via quasi-quoting built on top of @code{ghc-shakespeare}.")
+ (license license:bsd-3)))
+
(define-public ghc-yaml
(package
(name "ghc-yaml")