summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorCarlo Holl <carloholl@gmail.com>2020-10-31 19:02:22 -0700
committerChristopher Baines <mail@cbaines.net>2020-11-01 13:34:44 +0000
commit7f2a565070de18d9a1145e08e31777c1187acd1a (patch)
tree8066a1cee12f57593b645e78f940f19f80a49803 /gnu/packages/haskell-xyz.scm
parent9e775fa1a96e19edc23aae8a2d7f1a7d8d08d226 (diff)
downloadguix-patches-7f2a565070de18d9a1145e08e31777c1187acd1a.tar
guix-patches-7f2a565070de18d9a1145e08e31777c1187acd1a.tar.gz
gnu: Add ghc-control-monad-free.
* gnu/packages/haskell-xyz.scm (ghc-control-monad-free): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5b9da15630..c27eabdd74 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2020 JoJo <jo@jo.zone>
;;; Copyright © 2020 Nicolas Goaziou <mail@nicolasgoaziou.fr>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
+;;; Copyright © 2020 Carlo Holl <carloholl@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2608,6 +2609,36 @@ a vocabulary for working with them.")
@code{ghc-contravariant} package.")
(license license:expat)))
+(define-public ghc-control-monad-free
+ (package
+ (name "ghc-control-monad-free")
+ (version "0.6.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/"
+ "package/control-monad-free/control-monad-free-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "1habgf7byffqf1rqjkzpihvdhclaafgqsqpfpwp3fgpj5ayk1j33"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/pepeiborra/control-monad-free")
+ (synopsis "Free monads and monad transformers")
+ (description
+ "This package provides datatypes to construct Free monads, Free monad
+transformers, and useful instances. In addition it provides the constructs to
+avoid quadratic complexity of left associative bind, as explained in:
+
+@itemize @bullet
+@item
+Janis Voigtlander, @cite{Asymptotic Improvement of Computations over
+Free Monads, MPC'08}
+@end itemize")
+ (license license:public-domain)))
+
(define-public ghc-convertible
(package
(name "ghc-convertible")