summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-10 21:20:34 -0700
committerLeo Famulari <leo@famulari.name>2020-05-29 10:44:33 -0400
commit6c0858dda26dc1d3af8e546d9b1fda59175da9a0 (patch)
tree57c0b19abe73ba5df6a0a60f68417f05eebd15ed /gnu/packages/haskell-xyz.scm
parentdd26713e16e0ed6798820eabf1af7aef34ece12f (diff)
downloadguix-patches-6c0858dda26dc1d3af8e546d9b1fda59175da9a0.tar
guix-patches-6c0858dda26dc1d3af8e546d9b1fda59175da9a0.tar.gz
gnu: Add ghc-repline-0.3.
* gnu/packages/haskell-xyz.scm (ghc-repline-0.3): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 13a89e94b1..30a09bde8b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -10295,6 +10295,24 @@ inspired by libtre.")
normal mtl transformers.")
(license license:expat)))
+(define-public ghc-repline-0.3
+ (package
+ (inherit ghc-repline)
+ (version "0.3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/repline/repline-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0niihfyggg2qisadg7w49cr5k5qyyynia93iip0ng2bbmzwi88g8"))))
+ (inputs
+ `(("ghc-exceptions" ,ghc-exceptions)
+ ("ghc-haskeline" ,ghc-haskeline-0.8)))))
+
(define-public ghc-rerebase
(package
(name "ghc-rerebase")