summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 13:15:50 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:31 -0500
commit60e78e684e9627e9366f0c062d66caefbf3b7c03 (patch)
tree8bdcf88f5e467e47936df494fc59964d7830c5d6 /gnu/packages/haskell-xyz.scm
parente924e17e4a4ee91265f5804326c23a7e41edc689 (diff)
downloadguix-patches-60e78e684e9627e9366f0c062d66caefbf3b7c03.tar
guix-patches-60e78e684e9627e9366f0c062d66caefbf3b7c03.tar.gz
gnu: ghc-statistics: Update to 0.15.1.1.
* gnu/packages/haskell-xyz.scm (ghc-statistics): Update to 0.15.1.1. [arguments]: Remove '#:cabal-revision'. [inputs]: Remove 'ghc-erf'; add 'ghc-async' and 'ghc-dense-linear-algebra'.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 035b9636bb..58709be6b8 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9555,7 +9555,7 @@ in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
(define-public ghc-statistics
(package
(name "ghc-statistics")
- (version "0.14.0.2")
+ (version "0.15.1.1")
(source
(origin
(method url-fetch)
@@ -9564,17 +9564,16 @@ in the @code{IO} monad, like @code{IORef}s or parts of the OpenGL state.")
"statistics-" version ".tar.gz"))
(sha256
(base32
- "0y27gafkib0x0fn39qfn2rkgsfrm09ng35sbb5dwr7rclhnxz59l"))))
+ "015rn74f1glii26j4b2fh1fc63xvxzrh2xckiancz48kc8jdzabj"))))
(build-system haskell-build-system)
(arguments
- '(#:cabal-revision
- ("2" "1bx70yqkn62ii17fjv3pig4hklrzkqd09zj67zzjiyjzmn04fir3")
- ;; Two tests fail: "Discrete CDF is OK" and "Quantile is CDF inverse".
+ '(;; Two tests fail: "Discrete CDF is OK" and "Quantile is CDF inverse".
#:tests? #f))
(inputs
`(("ghc-aeson" ,ghc-aeson)
+ ("ghc-async" ,ghc-async)
("ghc-base-orphans" ,ghc-base-orphans)
- ("ghc-erf" ,ghc-erf)
+ ("ghc-dense-linear-algebra" ,ghc-dense-linear-algebra)
("ghc-math-functions" ,ghc-math-functions)
("ghc-monad-par" ,ghc-monad-par)
("ghc-mwc-random" ,ghc-mwc-random)