summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-18 21:41:10 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:55 -0500
commit59cd751852d1acab6eae6da0488d15cc743c2cc4 (patch)
tree21f702335623abd378f5f1b9561c81bc51239842 /gnu/packages/haskell-xyz.scm
parentb0d34d23a0e8bd5c3242bb631af61666a127f606 (diff)
downloadguix-patches-59cd751852d1acab6eae6da0488d15cc743c2cc4.tar
guix-patches-59cd751852d1acab6eae6da0488d15cc743c2cc4.tar.gz
gnu: ghc-foundation: Disable broken test.
* gnu/packages/haskell-xyz.scm (ghc-foundation)[arguments]: Add a phase that patches out a broken test.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm10
1 files changed, 10 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7bf97ae13c..fb6833207d 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4140,6 +4140,16 @@ and are often as efficient as hand-written folds.")
(base32
"0q6kx57ygmznlpf8n499hid4x6mj3180paijx0a8dgi9hh7man61"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ ;; This test is broken. For details, see
+ ;; https://github.com/haskell-foundation/foundation/issues/530
+ (add-after 'unpack 'patch-tests
+ (lambda _
+ (substitute* "tests/Test/Foundation/Number.hs"
+ ((", testDividible proxy") ""))
+ #t)))))
(inputs `(("ghc-basement" ,ghc-basement)))
(home-page "https://github.com/haskell-foundation/foundation")
(synopsis "Alternative prelude with batteries and no dependencies")