summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:38 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:52 +0100
commit546d057833954e2cfbe6d526f1a6a0cbe89fbc2d (patch)
tree85c030d369bbf2634beae570efc8ae5fbf920fe3 /gnu/packages/haskell-xyz.scm
parent2ee674ff3d9028bf93f6ed92ea9a6fc217e19715 (diff)
downloadguix-patches-546d057833954e2cfbe6d526f1a6a0cbe89fbc2d.tar
guix-patches-546d057833954e2cfbe6d526f1a6a0cbe89fbc2d.tar.gz
gnu: ghc-doclayout: Update to 0.3.1.1.
* gnu/packages/haskell-xyz.scm (ghc-doclayout): Update to 0.3.1.1. [inputs]: Add ghc-emojis. [native-inputs]: Add ghc-tasty-quickcheck.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index a15cb2700c..83f2568f72 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -9266,7 +9266,7 @@ Implementations using both of these examples are provided.")
(define-public ghc-doclayout
(package
(name "ghc-doclayout")
- (version "0.3.0.2")
+ (version "0.3.1.1")
(source
(origin
(method url-fetch)
@@ -9274,14 +9274,16 @@ Implementations using both of these examples are provided.")
"https://hackage.haskell.org/package/doclayout/"
"doclayout-" version ".tar.gz"))
(sha256
- (base32 "1hfqagf5rmdjjx3xzx153d769b2vwarmyx7k7cwh872cgasndb3q"))))
+ (base32 "1p9kgjlf7y4p1symvkwndgs4lvyw2c45bsgld09y9r4aiqbhdrxp"))))
(build-system haskell-build-system)
(inputs
- `(("ghc-safe" ,ghc-safe)))
+ `(("ghc-safe" ,ghc-safe)
+ ("ghc-emojis" ,ghc-emojis)))
(native-inputs
`(("ghc-tasty" ,ghc-tasty)
("ghc-tasty-golden" ,ghc-tasty-golden)
- ("ghc-tasty-hunit" ,ghc-tasty-hunit)))
+ ("ghc-tasty-hunit" ,ghc-tasty-hunit)
+ ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)))
(home-page "https://github.com/jgm/doclayout")
(synopsis "Pretty-printing library for laying out text documents")
(description