summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-13 00:28:31 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:52 -0500
commit4eb9a167d7ee97cc059e4276a9e7ae25a5ee4af4 (patch)
tree76ffa48767b5146d6652674a1b41832c18f01c18 /gnu/packages/haskell-xyz.scm
parentd8e4b750e19e3a619f0b6dee0eefb6c82f622fc0 (diff)
downloadguix-patches-4eb9a167d7ee97cc059e4276a9e7ae25a5ee4af4.tar
guix-patches-4eb9a167d7ee97cc059e4276a9e7ae25a5ee4af4.tar.gz
gnu: Add ghc-dictionary-sharing.
* gnu/packages/haskell-xyz.scm (ghc-dictionary-sharing): New variable.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 2e5f668a31..d68428ac8e 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2804,6 +2804,29 @@ related modules split from the statistics library.")
and parsers with useful semantics.")
(license license:bsd-3)))
+(define-public ghc-dictionary-sharing
+ (package
+ (name "ghc-dictionary-sharing")
+ (version "0.1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "dictionary-sharing/dictionary-sharing-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00aspv943qdqhlk39mbk00kb1dsa5r0caj8sslrn81fnsn252fwc"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:cabal-revision
+ ("3" "1mn7jcc7h3b8f1pn9zigqp6mc2n0qb66lms5qnrx4zswdv5w9439")))
+ (home-page "https://hackage.haskell.org/package/dictionary-sharing")
+ (synopsis "Sharing/memoization of class members")
+ (description "This library provides tools for ensuring that class
+members are shared.")
+ (license license:bsd-3)))
+
(define-public ghc-diff
(package
(name "ghc-diff")