summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2021-10-25 14:28:41 +0200
committerLars-Dominik Braun <lars@6xq.net>2021-11-02 09:32:54 +0100
commit4bed512ee1918802c038d698b76d6ef6cb68995e (patch)
treef484f0da07f15334d682c78618f33d212f1c98b4 /gnu/packages/haskell-xyz.scm
parent90d4d0d739e0cac336daabe774d2588c63cd972a (diff)
downloadguix-patches-4bed512ee1918802c038d698b76d6ef6cb68995e.tar
guix-patches-4bed512ee1918802c038d698b76d6ef6cb68995e.tar.gz
gnu: ghc-yaml: Update to 0.11.7.0.
* gnu/packages/haskell-xyz.scm (ghc-yaml): Update to 0.11.7.0. [inputs]: Remove ghc-semigroups, ghc-temporary, ghc-enclosed-exceptions, and ghc-base-compat; add ghc-optparse-applicative. [native-inputs]: Add ghc-base-compat and ghc-temporary.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm15
1 files changed, 7 insertions, 8 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 81d0352b3a..8745cc2289 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -15305,14 +15305,14 @@ code via quasi-quoting built on top of @code{ghc-shakespeare}.")
(define-public ghc-yaml
(package
(name "ghc-yaml")
- (version "0.11.5.0")
+ (version "0.11.7.0")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
"yaml/yaml-" version ".tar.gz"))
(sha256
(base32
- "1bfdsqckzql50j6ni4fa1470cvkmfiy4skb98cdwnj4rss5p93mj"))))
+ "0s08kw0hqxixxripwjmz7b4yh9130dws3jaj460x8ds8q4b6khbx"))))
(build-system haskell-build-system)
(inputs
`(("ghc-conduit" ,ghc-conduit)
@@ -15322,17 +15322,16 @@ code via quasi-quoting built on top of @code{ghc-shakespeare}.")
("ghc-vector" ,ghc-vector)
("ghc-attoparsec" ,ghc-attoparsec)
("ghc-scientific" ,ghc-scientific)
- ("ghc-semigroups" ,ghc-semigroups)
- ("ghc-temporary" ,ghc-temporary)
- ("ghc-enclosed-exceptions" ,ghc-enclosed-exceptions)
- ("ghc-base-compat" ,ghc-base-compat)
- ("ghc-libyaml" ,ghc-libyaml)))
+ ("ghc-libyaml" ,ghc-libyaml)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)))
(native-inputs
`(("ghc-hspec" ,ghc-hspec)
("ghc-hunit" ,ghc-hunit)
+ ("ghc-base-compat" ,ghc-base-compat)
("hspec-discover" ,hspec-discover)
("ghc-mockery" ,ghc-mockery)
- ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)))
+ ("ghc-raw-strings-qq" ,ghc-raw-strings-qq)
+ ("ghc-temporary" ,ghc-temporary)))
(home-page "https://github.com/snoyberg/yaml/")
(synopsis "Parsing and rendering YAML documents")
(description