summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorAlexandru-Sergiu Marton <brown121407@member.fsf.org>2020-01-07 13:33:36 -0600
committerBrett Gilio <brettg@gnu.org>2020-01-07 13:33:36 -0600
commit451775a5675cdf1dfb9f4503427442b21bb5041a (patch)
tree5bc662b46dc4a78083fa1bd06d61d12b2f92c312 /gnu/packages/haskell-xyz.scm
parent4639fa325c212eec7e2d45693d1ddf04287c316a (diff)
downloadguix-patches-451775a5675cdf1dfb9f4503427442b21bb5041a.tar
guix-patches-451775a5675cdf1dfb9f4503427442b21bb5041a.tar.gz
gnu: Add ghc-pointedlist.
* gnu/packages/haskell-xyz.scm (ghc-pointedlist): New variable. Signed-off-by: Brett Gilio <brettg@gnu.org>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index d3d4896f82..3a9880f58c 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -8659,6 +8659,31 @@ dependencies
@end itemize")
(license license:bsd-3)))
+(define-public ghc-pointedlist
+ (package
+ (name "ghc-pointedlist")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/pointedlist/"
+ "pointedlist-" version ".tar.gz"))
+ (sha256
+ (base32
+ "16xsrzqql7i4z6a3xy07sqnbyqdmcar1jiacla58y4mvkkwb0g3l"))))
+ (build-system haskell-build-system)
+ (home-page
+ "http://hackage.haskell.org/package/pointedlist")
+ (synopsis
+ "Zipper-like comonad which works as a list, tracking a position")
+ (description
+ "A PointedList tracks the position in a non-empty list which works
+similarly to a zipper. A current item is always required, and therefore
+the list may never be empty. A circular PointedList wraps around to the
+other end when progressing past the actual edge.")
+ (license license:bsd-3)))
+
(define-public ghc-polyparse
(package
(name "ghc-polyparse")