summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorVagrant Cascadian <vagrant@debian.org>2021-12-30 18:39:42 -0800
committerVagrant Cascadian <vagrant@debian.org>2021-12-30 19:11:46 -0800
commit38376090c34653027d4967365dbd985ec0bd3459 (patch)
treea635d9d5eb1e389d251cd0925c02cabcb6d4dd93 /gnu/packages/haskell-xyz.scm
parentd422848146f4b7d6aaec20776daaac8964416a0f (diff)
downloadguix-patches-38376090c34653027d4967365dbd985ec0bd3459.tar
guix-patches-38376090c34653027d4967365dbd985ec0bd3459.tar.gz
gnu: Remove trailing period from synopsis.
* gnu/packages/anddroid.scm (android-liblog, git-repo)[synopsis]: Remove trailing period. * gnu/packages/audio.scm (audio-to-midi)[synopsis]: Likewise. * gnu/packages/bioinformatics.scm (python-mygene, python-scanpy, nanosv)[synopsis]: Likewise. * gnu/packages/cran.scm (r-gsubfn)[synopsis]: Likewise. * gnu/packages/crates-io.scm (rust-ascii-1, rust-bindgen-0.59, rust-byte-unit-4, rust-clircle-0.3, rust-dashmap-4, rust-dhcp4r-0.2, rust-fast-float-0.2, rust-fst-0.4, rust-futures-core-preview-0.3, rust-http-types-2, rust-hyper-0.14, rust-indexmap-1, rust-minimal-lexical-0.1, rust-oorandom-11.1, rust-runtime-raw-0.3, rust-sharded-slab-0.1, rust-takeable-option-0.4, rust-tower-service-0.3, rust-ttf-parser-0.12)[synopsis]: Likewise. * gnu/packages/disk.scm (f3)[synopsis]: Likewise. * gnu/packages/emacs-xyz.scm (emacs-scribble-mode, emacs-psession)[synopsis]: Likewise. * gnu/packages/golang.scm (go-github-com-kylelemons-godebug)[synopsis]: Likewise. * gnu/packages/haskell-xyz.scm (ghc-fsnotify, ghc-libyaml, ghc-emojis, ghc-regex-tdfa, ghc-th-lift-instances, ghc-commonmark-pandoc)[synopsis]: Likewise. * gnu/packages/java.scm (java-commons-jxpath, java-jakarta-regexp)[synopsis]: Likewise. * gnu/packages/lisp-xyz.scm (sbcl-cl-annot, sbcl-envy)[synopsis]: Likewise. * gnu/packages/mail.scm (go-gitlab.com-shackra-goimapnotify)[synopsis]: Likewise. * gnu/packages/maven.scm (maven-wagon-http-shared, maven-surefire-plugin)[synopsis]: Likewise. * gnu/packages/perl.scm (perl-text-soundex)[synopsis]: Likewise. * gnu/packages/python-check.scm (python-httmock)[synopsis]: Likewise. * gnu/packages/python-web.scm (python-bottle)[synopsis]: Likewise. * gnu/packages/python-xyz.scm (python-olefile, python-tokenize-rt, python-pylzma)[synopsis]: Likewise. * gnu/packages/tex.scm (texlive-docstrip)[synopsis]: Likewise.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index e88e42843e..630ca00cdc 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -4528,7 +4528,7 @@ definition of @code{Monad}.")
ghc-shelly
ghc-temporary))
(home-page "https://github.com/haskell-fswatch/hfsnotify")
- (synopsis "Cross platform library for file change notification.")
+ (synopsis "Cross platform library for file change notification")
(description "Cross platform library for file creation, modification, and
deletion notification. This library builds upon existing libraries for platform
specific Windows, Mac, and Linux file system event notification.")
@@ -6941,7 +6941,7 @@ compiler versions.")
(inputs
(list ghc-conduit ghc-resourcet libyaml+static))
(home-page "https://github.com/snoyberg/yaml#readme")
- (synopsis "Low-level, streaming YAML interface.")
+ (synopsis "Low-level, streaming YAML interface")
(description "This package provides a Haskell wrapper over the
LibYAML C library.")
(license license:bsd-3)))
@@ -8768,7 +8768,7 @@ to other formats.")
(native-inputs
(list ghc-hunit))
(home-page "https://github.com/jgm/emojis#readme")
- (synopsis "Conversion between emoji characters and their names.")
+ (synopsis "Conversion between emoji characters and their names")
(description
"This package provides functions for converting emoji names to emoji
characters and vice versa.
@@ -10638,7 +10638,7 @@ Haskell library @code{regex-base}.")
(list ghc-regex-base))
(native-inputs (list ghc-utf8-string))
(home-page "https://github.com/haskell-hvr/regex-tdfa")
- (synopsis "POSIX extended regular expressions in Haskell.")
+ (synopsis "POSIX extended regular expressions in Haskell")
(description
"Regex-tdfa is a pure Haskell regular expression library implementing POSIX
extended regular expressions. It is a \"tagged\" DFA regex engine. It is
@@ -12893,7 +12893,7 @@ datatypes.")
(inputs
(list ghc-th-lift ghc-vector ghc-quickcheck))
(home-page "https://github.com/bennofs/th-lift-instances/")
- (synopsis "Lift instances for template-haskell for common data types.")
+ (synopsis "Lift instances for template-haskell for common data types")
(description "Most data types in the Haskell platform do not have Lift
instances. This package provides orphan instances for @code{containers},
@code{text}, @code{bytestring} and @code{vector}.")
@@ -15309,7 +15309,7 @@ footnotes, math, and more.")
(inputs
(list ghc-commonmark ghc-commonmark-extensions ghc-pandoc-types))
(home-page "https://github.com/jgm/commonmark-hs")
- (synopsis "Bridge between Commonmark and Pandoc AST.")
+ (synopsis "Bridge between Commonmark and Pandoc AST")
(description
"This library provides typeclasses for rendering @code{ghc-commonmark} to
Pandoc types.")