summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-04-10 21:08:27 -0700
committerLeo Famulari <leo@famulari.name>2020-05-29 10:44:30 -0400
commit2b2c8911c6357312ca577c20dbe6fc58ffa98aa5 (patch)
treedd07cd3d4208cbebe1e2862163cf09d470ab90ac /gnu/packages/haskell-xyz.scm
parent5434fec95da8f73f0422140f6b61cc918184a77e (diff)
downloadguix-patches-2b2c8911c6357312ca577c20dbe6fc58ffa98aa5.tar
guix-patches-2b2c8911c6357312ca577c20dbe6fc58ffa98aa5.tar.gz
gnu: Add ghc-dotgen.
* gnu/packages/haskell-xyz.scm (ghc-dotgen): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 7ca80d6bae..fb26de2669 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3342,6 +3342,30 @@ It is modeled after doctest for Python, see
@uref{https://docs.python.org/library/doctest.html, the Doctest website}.")
(license license:expat)))
+(define-public ghc-dotgen
+ (package
+ (name "ghc-dotgen")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://hackage/package/dotgen/dotgen-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "148q93qsmqgr5pzdwvpjqfd6bdm1pwzcp2rblfwswx2x8c5f43fg"))))
+ (build-system haskell-build-system)
+ (home-page "https://github.com/ku-fpg/dotgen")
+ (synopsis
+ "Simple interface for building .dot graph files")
+ (description
+ "This package provides a simple interface for building .dot graph
+files, for input into the dot and graphviz tools. It includes a
+monadic interface for building graphs.")
+ (license license:bsd-3)))
+
(define-public ghc-double-conversion
(package
(name "ghc-double-conversion")