summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-xyz.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-10-31 14:28:24 -0400
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:44 -0500
commit2648b604ac112839933b450ad21f01fb6a22a6ff (patch)
tree32d44f95c2afb27e8380dfca1369e42e49fae4ec /gnu/packages/haskell-xyz.scm
parent801fbd7e0f9a4de2082e5946b5641473c951d0b0 (diff)
downloadguix-patches-2648b604ac112839933b450ad21f01fb6a22a6ff.tar
guix-patches-2648b604ac112839933b450ad21f01fb6a22a6ff.tar.gz
gnu: ghc-esqueleto: Update to 3.0.0.
* gnu/packages/haskell-xyz.scm (ghc-esqueleto): Update to 3.0.0. [source]: Use 'url-fetch' instead of 'git-fetch'.
Diffstat (limited to 'gnu/packages/haskell-xyz.scm')
-rw-r--r--gnu/packages/haskell-xyz.scm113
1 files changed, 54 insertions, 59 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 5b6aa93a7a..37f56df89b 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -3209,69 +3209,64 @@ directly uses the type system, rather than out-of-band exceptions.")
(license license:bsd-3)))
(define-public ghc-esqueleto
- (let ((version "2.5.3")
- (revision "1")
- (commit "b81e0d951e510ebffca03c5a58658ad884cc6fbd"))
- (package
- (name "ghc-esqueleto")
- (version (git-version version revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/bitemyapp/esqueleto")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0lz1qxms7cfg5p3j37inlych0r2fwhm8xbarcys3df9m7jy9nixa"))))
- (build-system haskell-build-system)
- (arguments
- `(#:haddock? #f ; Haddock reports an internal error.
- #:phases
- (modify-phases %standard-phases
- ;; This package normally runs tests for the MySQL, PostgreSQL, and
- ;; SQLite backends. Since we only have Haskell packages for
- ;; SQLite, we remove the other two test suites. FIXME: Add the
- ;; other backends and run all three test suites.
- (add-before 'configure 'remove-non-sqlite-test-suites
- (lambda _
- (use-modules (ice-9 rdelim))
- (with-atomic-file-replacement "esqueleto.cabal"
- (lambda (in out)
- (let loop ((line (read-line in 'concat)) (deleting? #f))
- (cond
- ((eof-object? line) #t)
- ((string-every char-set:whitespace line)
- (unless deleting? (display line out))
- (loop (read-line in 'concat) #f))
- ((member line '("test-suite mysql\n"
- "test-suite postgresql\n"))
- (loop (read-line in 'concat) #t))
- (else
- (unless deleting? (display line out))
- (loop (read-line in 'concat) deleting?)))))))))))
- (inputs
- `(("ghc-blaze-html" ,ghc-blaze-html)
- ("ghc-conduit" ,ghc-conduit)
- ("ghc-monad-logger" ,ghc-monad-logger)
- ("ghc-persistent" ,ghc-persistent)
- ("ghc-resourcet" ,ghc-resourcet)
- ("ghc-tagged" ,ghc-tagged)
- ("ghc-unliftio" ,ghc-unliftio)
- ("ghc-unordered-containers" ,ghc-unordered-containers)))
- (native-inputs
- `(("ghc-hspec" ,ghc-hspec)
- ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
- ("ghc-persistent-template" ,ghc-persistent-template)))
- (home-page "https://github.com/bitemyapp/esqueleto")
- (synopsis "Type-safe embedded domain specific language for SQL queries")
- (description "This library provides a type-safe embedded domain specific
+ (package
+ (name "ghc-esqueleto")
+ (version "3.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "esqueleto/esqueleto-" version ".tar.gz"))
+ (sha256
+ (base32
+ "187c098h2xyf2nhifkdy2bqfl6iap7a93mzwd2kirl5yyicpc9zy"))))
+ (build-system haskell-build-system)
+ (arguments
+ `(#:haddock? #f ; Haddock reports an internal error.
+ #:phases
+ (modify-phases %standard-phases
+ ;; This package normally runs tests for the MySQL, PostgreSQL, and
+ ;; SQLite backends. Since we only have Haskell packages for
+ ;; SQLite, we remove the other two test suites. FIXME: Add the
+ ;; other backends and run all three test suites.
+ (add-before 'configure 'remove-non-sqlite-test-suites
+ (lambda _
+ (use-modules (ice-9 rdelim))
+ (with-atomic-file-replacement "esqueleto.cabal"
+ (lambda (in out)
+ (let loop ((line (read-line in 'concat)) (deleting? #f))
+ (cond
+ ((eof-object? line) #t)
+ ((string-every char-set:whitespace line)
+ (unless deleting? (display line out))
+ (loop (read-line in 'concat) #f))
+ ((member line '("test-suite mysql\n"
+ "test-suite postgresql\n"))
+ (loop (read-line in 'concat) #t))
+ (else
+ (unless deleting? (display line out))
+ (loop (read-line in 'concat) deleting?)))))))))))
+ (inputs
+ `(("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-conduit" ,ghc-conduit)
+ ("ghc-monad-logger" ,ghc-monad-logger)
+ ("ghc-persistent" ,ghc-persistent)
+ ("ghc-resourcet" ,ghc-resourcet)
+ ("ghc-tagged" ,ghc-tagged)
+ ("ghc-unliftio" ,ghc-unliftio)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
+ ("ghc-persistent-template" ,ghc-persistent-template)))
+ (home-page "https://github.com/bitemyapp/esqueleto")
+ (synopsis "Type-safe embedded domain specific language for SQL queries")
+ (description "This library provides a type-safe embedded domain specific
language (EDSL) for SQL queries that works with SQL backends as provided by
@code{ghc-persistent}. Its language closely resembles SQL, so you don't have
to learn new concepts, just new syntax, and it's fairly easy to predict the
generated SQL and optimize it for your backend.")
- (license license:bsd-3))))
+ (license license:bsd-3)))
(define-public ghc-exactprint
(package