summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2020-12-04 20:15:39 +0100
committerTimothy Sample <samplet@ngyro.com>2020-12-06 21:34:46 -0500
commitfd076aefcdffe83439dcc75fa71c310de37e51e6 (patch)
treea812b8c3a3240acc055b33c9b165cbebf8317050 /gnu/packages/haskell-web.scm
parent2e77bb473bf1ca19047f05e8acda48217a1c0769 (diff)
downloadguix-patches-fd076aefcdffe83439dcc75fa71c310de37e51e6.tar
guix-patches-fd076aefcdffe83439dcc75fa71c310de37e51e6.tar.gz
gnu: Add ghc-wai-app-static.
* gnu/packages/haskell-web.scm (ghc-wai-app-static): New variable. Signed-off-by: Timothy Sample <samplet@ngyro.com>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 26ac1ac7c1..88f7b6e1d9 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -2073,3 +2073,49 @@ test. Tests are like browser sessions that keep track of cookies and
the last visited page. You can perform assertions on the content of
HTML responses using CSS selectors.")
(license license:expat)))
+
+(define-public ghc-wai-app-static
+ (package
+ (name "ghc-wai-app-static")
+ (version "3.1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "wai-app-static/wai-app-static-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "10k6jb450p89r6dgpnwh428gg0wfw2qbx9n126jkvbchcjr1f4v8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-wai" ,ghc-wai)
+ ("ghc-http-types" ,ghc-http-types)
+ ("ghc-unix-compat" ,ghc-unix-compat)
+ ("ghc-old-locale" ,ghc-old-locale)
+ ("ghc-file-embed" ,ghc-file-embed)
+ ("ghc-cryptonite" ,ghc-cryptonite)
+ ("ghc-memory" ,ghc-memory)
+ ("ghc-http-date" ,ghc-http-date)
+ ("ghc-blaze-html" ,ghc-blaze-html)
+ ("ghc-blaze-markup" ,ghc-blaze-markup)
+ ("ghc-mime-types" ,ghc-mime-types)
+ ("ghc-unordered-containers" ,ghc-unordered-containers)
+ ("ghc-zlib" ,ghc-zlib)
+ ("ghc-wai-extra" ,ghc-wai-extra)
+ ("ghc-optparse-applicative" ,ghc-optparse-applicative)
+ ("ghc-warp" ,ghc-warp)))
+ (native-inputs
+ `(("ghc-hspec" ,ghc-hspec)
+ ("ghc-network" ,ghc-network)
+ ("ghc-temporary" ,ghc-temporary)
+ ("ghc-mockery" ,ghc-mockery)))
+ (arguments
+ `(#:cabal-revision
+ ("1" "0bkmml30rzifvb7nxddj3pxczk0kniahra19mjn0qrkzy1n5752p")))
+ (home-page "https://www.yesodweb.com/book/web-application-interface")
+ (synopsis "WAI application for static serving")
+ (description "This package provides a Web Application
+Interface (WAI) application for static serving. It also provides some
+helper functions and datatypes for use outside of WAI.")
+ (license license:expat)))