summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-27 22:36:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-13 16:44:58 +0200
commitf79e4b1fcd2bf082610e868fbd4c9e5c505c9f49 (patch)
treeb5bc2e864858819b73d57b5b2a7def07c1b176ae /gnu/packages/haskell-web.scm
parentc7891956cdccfb5ecd2c4770e9b7e04bcff5d861 (diff)
downloadguix-patches-f79e4b1fcd2bf082610e868fbd4c9e5c505c9f49.tar
guix-patches-f79e4b1fcd2bf082610e868fbd4c9e5c505c9f49.tar.gz
gnu: ghc-http: Prevent embedding of spurious references.
* gnu/packages/haskell-web.scm (ghc-http)[arguments]: Add build phase "create-simple-paths-module" to avoid retaining unnecessary references.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm18
1 files changed, 17 insertions, 1 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 5931fcaea5..b9474c973a 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -197,7 +197,23 @@ both client and server code).")
("ghc-network-uri" ,ghc-network-uri)
("ghc-split" ,ghc-split)))
(arguments
- `(#:tests? #f)) ; FIXME: currently missing libraries used for tests.
+ `(#:tests? #f ; FIXME: currently missing libraries used for tests.
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'create-simple-paths-module
+ (lambda _
+ (call-with-output-file "Paths_HTTP.hs"
+ (lambda (port)
+ (format port "\
+{-# LANGUAGE CPP #-}
+{-# LANGUAGE NoRebindableSyntax #-}
+{-# OPTIONS_GHC -fno-warn-missing-import-lists #-}
+module Paths_HTTP (version) where
+import Data.Version (Version(..))
+version :: Version
+version = Version [~a] []
+" (string-map (lambda (chr) (if (eq? chr #\.) #\, chr)) ,version))))
+ #t)))))
(home-page "https://github.com/haskell/HTTP")
(synopsis "Library for client-side HTTP")
(description