summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2018-09-03 09:53:24 -0400
committerRicardo Wurmus <rekado@elephly.net>2018-10-01 12:12:10 +0200
commite95cc1087a13ab4c26244c31b7e6512c37042a5b (patch)
tree878dbc15757abf719f15a6e80d228e8aba93269c /gnu/packages/haskell-web.scm
parentecefe4ce870e69009117d8e14382ad9c2e69720d (diff)
downloadguix-patches-e95cc1087a13ab4c26244c31b7e6512c37042a5b.tar
guix-patches-e95cc1087a13ab4c26244c31b7e6512c37042a5b.tar.gz
gnu: Add ghc-bsb-http-chunked.
* gnu/packages/haskell-web.scm (ghc-bsb-http-chunked): New variable.
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 0a53136f97..190bec8dd2 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -524,6 +524,30 @@ functionality.")
Haskell's Web Application Interface (WAI).")
(license license:expat)))
+(define-public ghc-bsb-http-chunked
+ (package
+ (name "ghc-bsb-http-chunked")
+ (version "0.0.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://hackage.haskell.org/package/"
+ "bsb-http-chunked/bsb-http-chunked-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1x6m6xkrcw6jiaig1bb2wb5pqyw31x8xr9k9pxgq2g3ng44pbjr8"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-bytestring-builder" ,ghc-bytestring-builder)))
+ (home-page "http://github.com/sjakobi/bsb-http-chunked")
+ (synopsis "Chunked HTTP transfer encoding for bytestring builders")
+ (description "This Haskell library contains functions for encoding
+bytestring builders for chunked Hypertext Transfer Protocol (HTTP) 1.1
+transfers.")
+ (license license:bsd-3)))
+
(define-public ghc-warp
(package
(name "ghc-warp")