summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2022-03-26 23:26:03 -0400
committerLeo Famulari <leo@famulari.name>2022-03-29 12:53:26 -0400
commite59069fe2b1cc7bdbd0f872cc4688df41350eba8 (patch)
tree4f1487e0b27800b1acaab7ee36166c206397a021 /gnu/packages/haskell-web.scm
parentf40c72327e9d8bd2b290c37a5b161dc7e26325f4 (diff)
downloadguix-patches-e59069fe2b1cc7bdbd0f872cc4688df41350eba8.tar
guix-patches-e59069fe2b1cc7bdbd0f872cc4688df41350eba8.tar.gz
gnu: Add ghc-http-client-restricted.
* gnu/packages/haskell-web.scm (ghc-http-client-restricted): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index cafdf5099e..1c2538b45e 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -9,7 +9,7 @@
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@gmail.com>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
-;;; Copyright © 2020 Kyle Meyer <kyle@kyleam.com>
+;;; Copyright © 2020, 2022 Kyle Meyer <kyle@kyleam.com>
;;; Copyright © 2020 Alexandru-Sergiu Marton <brown121407@member.fsf.org>
;;; Copyright © 2020 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
@@ -292,6 +292,34 @@ connection and TLS libraries. It is intended for use by higher-level
libraries, such as http-conduit.")
(license license:expat)))
+(define-public ghc-http-client-restricted
+ (package
+ (name "ghc-http-client-restricted")
+ (version "0.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (hackage-uri "http-client-restricted" version))
+ (sha256
+ (base32 "1vfm9qc3zr0rmq2ddgyg13i67020cdk8xqhyzfc2zcn1km2p6r85"))))
+ (build-system haskell-build-system)
+ (inputs
+ (list ghc-http-client
+ ghc-http-client-tls
+ ghc-connection
+ ghc-data-default
+ ghc-network
+ ghc-network-bsd
+ ghc-utf8-string))
+ (home-page "http://hackage.haskell.org/package/http-client-restricted")
+ (synopsis "Restrict the servers used by http-client")
+ (description
+ "This library makes it possible to restrict the HTTP servers that can be
+used by the @code{http-client} and @code{http-client-tls} libraries. This is
+useful when a security policy needs to, e.g., prevent connections to HTTP
+servers on localhost or only allow connections to a specific server.")
+ (license license:expat)))
+
(define-public ghc-http-date
(package
(name "ghc-http-date")