summaryrefslogtreecommitdiff
path: root/gnu/packages/haskell-web.scm
diff options
context:
space:
mode:
authorKyle Meyer <kyle@kyleam.com>2022-03-26 23:26:01 -0400
committerLeo Famulari <leo@famulari.name>2022-03-29 12:53:25 -0400
commitd2984784fd2ca4fbe8015feecae5df158180c421 (patch)
tree60c6772a270821f1bc2c87b916e589d2e4af44aa /gnu/packages/haskell-web.scm
parent591007f7d12d598fe0eda698da07e79b180d1946 (diff)
downloadguix-patches-d2984784fd2ca4fbe8015feecae5df158180c421.tar
guix-patches-d2984784fd2ca4fbe8015feecae5df158180c421.tar.gz
gnu: ghc-http-client: Update to 0.7.11.
* gnu/packages/haskell-web.scm (ghc-http-client): Update to 0.7.11. [inputs]: Add ghc-iproute. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/haskell-web.scm')
-rw-r--r--gnu/packages/haskell-web.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/haskell-web.scm b/gnu/packages/haskell-web.scm
index 70a4eccce6..470a0a02be 100644
--- a/gnu/packages/haskell-web.scm
+++ b/gnu/packages/haskell-web.scm
@@ -221,7 +221,7 @@ responses coming back.")
(define-public ghc-http-client
(package
(name "ghc-http-client")
- (version "0.6.4.1")
+ (version "0.7.11")
(source (origin
(method url-fetch)
(uri (string-append "https://hackage.haskell.org/package/"
@@ -229,7 +229,7 @@ responses coming back.")
version ".tar.gz"))
(sha256
(base32
- "1y12xfh6xvsfvyapbssmgrpjz025rmyccprbnmzhs0y1cmlz6hjp"))))
+ "12j7vkpkm2djws6ny7vm2324c7916d0iaf1mbvf4mfjxzy2w7imv"))))
(build-system haskell-build-system)
;; Tests require access to the web.
(arguments `(#:tests? #f))
@@ -242,6 +242,7 @@ responses coming back.")
ghc-data-default-class
ghc-exceptions
ghc-http-types
+ ghc-iproute
ghc-memory
ghc-mime-types
ghc-monad-control